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Coloring Notes in Sibelius Using Colored Notehead Styles 
 

Bob Zawalich November 10, 2016 
 
The problem: coloring notes in chords 
 
Sibelius has long had the ability to apply colors to notes, as well as to other objects.  Unfortunately, if 
you apply a color to any note in a chord of notes in the same voice, all the notes in that chord will be 
given the same color. 
 

 
 
 
I note that as of Sibelius 8.3, individual notes can have their own color, so you will not need to use 
these plugins to get colored notes in a chord. (Yay!) 
 
One solution: apply noteheads with colors to notes (Sibelius 7 and later only) 
 
Kai Struck and I have recently developed a mechanism allowing noteheads to have individual colors 
in chords. Our solution is to create special colored notehead styles, which can be applied to notes 
using Notations > Noteheads >Type. 
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Here is the set of colors we have made available: 

 
 
White is also now available, though it does not appear in this illustration. 
 
There are also collections of colors that can be imported as a group of 25, 12, 7, or 2 colors, which 
gives you access to colored noteheads even in a score that does not have room for the full set of 25 
colors. Rainbow replaces the expected yellow with brown, since yellow notes are very hard to see. 
 

 
 
This document will describe how Colored Notehead Styles can be used, and describes some tools to 
make it easier. 
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How to use Colored Notehead Styles  
 
Below you will find details about various things you can do with colored notehead styles, but using 
them really boils down to this. 
 

1. Install the plugin suite Colored Notehead Styles with the Sibelus 7 Plugin Installer from  
category Color. 

2. Install the plugin Color Enharmonic Pitches, also from category Color. 
3. Run Color Enharmonic Pitches to add colors to your notes, according to their pitch. This is 

described in more detail below. 
4. To remove colored noteheads, select the colored notes and apply the notehead style Normal 

from Notations > Noteheads >Type. 
 
The Colored Noteheads Plugin Suite 
 
Files and plugins for managing colored notehead styles can be installed using the Sibelius 7 plugin 
installer found at File > Plug-ins > Install Plug-ins. In the installer, go to All plug-ins, and category 
Color, and install Colored Notehead Styles. 
 

 
 
This will install several plugins: 
 
Import Colored Notehead Styles 
Colored Noteheads On Harp Strings 
Colored Noteheads On Strings 
Remove Colored Noteheads 
Colored Notehead Data File 
 
and will place 2 data files, Colored Notehead Styles.sib and Colored Notehead Styles_Bordered.sib, in 
the For plug-ins subfolder of your user Manuscript papers folder. (Don’t worry about this). 
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There are some other plugins that are not in the suite but which can also work with colored notehead 
styles. These are: 
 
Color Enharmonic Pitches (category Color) 
Filter Other (category Filter and Find) 
 
 
The Details 
 
The data file Colored Notehead Styles.sib and the plugin Import Colored Notehead Styles must be 
installed for anything else to work, and these will be installed if you use the Sibelius 7 Plugin Installer 
to install Colored Notehead Styles. 
 
Colored Notehead Styles.sib contains notes with colored notehead styles, and the plugins will copy 
notes from that score into the score you are working on as a way to import the style definitions. When 
you run one of the colored notehead plugins you will see a score with colored notes briefly appear on 
the screen, then go away, as notes are copied from it and pasted into the working score. If something 
unexpected happens, and the score with the colored noteheads is not closed, just close it without 
saving changes. It is only a copy of the data file, so the original data file will not be affected. 
 
Once you have installed the suite, you should install the current version of Color Enharmonic Pitches 
(category Color), which is the major tool available, and Filter Other (category Filter and Find). 
 
Color Enharmonic Pitches lets you specify colors for any pitches in the selection. It will import the full 
set of 25 colors. If your score has a notehead style number greater than 39, the option to use colored 
notehead styles will be disabled, and you will need to use other mechanisms to use colored notehead 
styles with that score. 
 
If you have room to import the notehead styles, you will see this dialog, with the option to use colored 
notehead styles enabled. 
 
Choose colors to apply to selected notes. If you want equivalent sounding pitches (such as C# and Db) 
to be colored the same, use the Sharp = Flat or Flat = Sharp buttons.  
 
Save as Defaults sets the colors currently in the dialog to be the default colors. Set to Defaults sets all 
the note names lists to Leave color as is or the colors saved in 'Save as Defaults'. 
 
To set only a few colors, use All Black to make all pitches black, or Clear All to mark all pitches 
unchanged (Leave color as is), and then choose the pitches you want to color. 
 



5 
 

  
 
To remove colored notehead styles for notes, select them and use Notations >Noteheads > Type to set 
the notehead style to Normal, or run the plugin Remove Colored Notehead Styles, which will remove 
some or all colored noteheads, giving them Normal style. Or you can run Color Enharmonic Pitches 
and use the All Black option. 
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The plugin Filter Other, which is not part of the suite but which can be installed from category Filter 
and Find, can filter for a specific colored notehead style using Noteheads, or for all colored notehead 
styles, using Colored Notehead Styles. At present, the Colored Objects entry will not filter notes with 
colored notehead styles. 
 

 
 
If your score does not have room for the 25 notehead styles that Color Enharmonic Pitches needs, you 
can import a smaller set by running Import Colored Notehead Styles, and then apply the styles 
manually to pitches using Notations > Noteheads >Type. When you run Import Colored Notehead 
Styles, you can choose colors from this dialog: 
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One special plugin, Color Noteheads on Harp Strings, is intended for use only with harps. It will 
allow you to import different numbers of colors using this dialog: 
 

 
 
Once you import the notehead styles, you can apply colors to notes based upon which string they are 
found on a harp, rather than being based on the pitch. On a harp, the pitches Cb, C, and C# will be on 
the same string, though not at the same time, using pedals or levers to change the pitches. 
 
Here is one example, where notes on all strings except the C and F strings will be black, while the C 
string notes will be Red, and the F string notes will be Blue. 
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Colored Noteheads On Strings is a similar plugin that colors notes on stringed instruments with 
fingerboards based on which string the notes are located. Unlike harps, on these instruments the 
same note can be present on multiple strings, and different mechanisms need to be used to determine 
the mapping of pitches and strings. 
 
The document String numbers for notes in stringed instruments in Sibelius, included in this zip file, 
discusses different ways to associate strings with pitches. It should be read before using the plugin. 
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Colored notehead styles: differences and limitations 
 
The major advantage of using colored notehead styles is that each note in a color can have its own 
color, but the colored notes produced by colored notehead styles look different than those produced 
by applying color to notes using Home > Edit > Color.  
 
If colored notehead styles are used, only the notehead itself is colored.  Accidentals, accents, ties, 
brackets, and rhythm dots, which are given the note color using normal coloring, are left black when 
colored notehead styles are used. This is not unprecedented – if you use View > Note Colors > Voice 
Colors, you will also see only the noteheads colored, as in the example below. 

 
coloring using Voice Colors 
 
I actually prefer the way the notes look with only the colored notehead, and it really makes sense to 
not color accents in a chord, but you should be aware that the appearance will be different if you color 
with colored notehead styles. 

 
There are some definite limitations involved in using colored notehead styles. The major one is that 
Sibelius has an internal limit of 64 notehead styles in a score. You can create more, but any style with 
a number over 63 will not give the correct result. A new score in Sibelius 7 will come with 31 notehead 
styles already included, so you can add at most 33 new styles.  
 
The plugins try to be smart about this. They will check to see if any of the notehead styles you are 
asking to import are already defined in the target score. If they are defined, the style will not count 
against the total number allowed, and styles will not be imported multiple times. 
 
Another limitation is that a colored notehead style must specify a note shape. We have chosen to 
create colored notehead styles for Opus noteheads in the Normal shape. If you want colored 
noteheads for other fonts or other noteheads, it is possible to create them, and instructions will be 
given in this document, but it is not trivial to do that. 
 
What we have done is to make available a set of 25 colored noteheads based on the Normal shape of 
the Opus font. The colors I have chosen match the “named” colors I have used in plugins such as 
Apply Name Colors, Color Enharmonic Pitches, and others.  25 Notehead styles can be added safely 
to any score that does not have any user-defined notehead styles. 
To set a note to the equivalent of the color Black, set its notehead style to be Normal. Most of the 
plugins will not apply a colored notehead styles to a note if it has a style other than Normal or one of 
the colored notehead styles, so cross and beat noteheads will not be changed by the plugins.  
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How everything works, featuring the Data File 
 
The file Colored Notehead Styles.sib is a Sibelius version 7.1-format score containing notes that have 
special notehead styles. 
 
To make up those styles, Kai Struck took my list of RGB color values used in other plugins, and made 
up a set of quarter note, half note, and whole note noteheads, linking to the Opus font note shapes, as 
SVG graphics files for each color. (Kai actually made up noteheads for many more colors than these, 
but these are all that I wanted to use). 
 
I created a set of symbols in a new Sibelius 7 score for each of these noteheads, and you can see them 
in Notations > Symbols > Edit Symbol if you look in a score with imported colored notehead styles. 
 

 
 
I then created 25 notestyles, each notestyle using the 3 symbols for each color. We did not create color 
versions of the double whole notes because we doubted anyone would use them. 
 
My plan was to create House Styles for these, and then import the noteheads into a score. 
Unfortunately, when you import notehead styles, you also get the text styles from that House Style, 
and if you had something like an Inkpen or Reprise score, the text would be replaced, which was not 
desirable. 
 
So I decided that I would just create a score from which notes could be copied into another score, and 
then the notes could be deleted from that score. Even after deleting, this imports the symbols and 
notehead styles associated with the pasted notes. 
 
Eventually, plugins were written that would read the data file to find the notes it wanted, and copy 
them into the target score. The data file, which acts as a database for the plugins, looks like this: 
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Each bar has a piece of text that identifies the notehead style, and it has a set of quarter, half, and 
whole notes that use that notehead style. 
 
 
  



13 
 

Making your own custom data score 
 
The current version of the plugin suite allows you to create multiple data scores that contain 
different notehead definitions. The suite contains Colored Notehead Styles.sib and Colored 
Notehead Styles_Bordered.sib, which uses colored noteheads with borders. 
 

 
 
Be careful to only use one set of custom notehead styles in a single score. The symbol 
names will get duplicated otherwise, and the second set will not be found. There is no easy way to 
get rid of a set of notehead symbols once they are created, so it is best to never create them. 
 
You can create any noteheads you like using SVG graphics for the symbols. If you want to take 
advantage of the plugins to assign notehead styles to pitches you need to create a data score with a 
very specific format.  
 
You can make up a custom data file this way: 
 

 Make a copy of the original Colored NoteheadStyle.sib and give it a unique name that 

adds a suffix to that name, as in my example Colored Notehead Styles_Bordered.sib. 

Save it in the For Plug-ins folder of your user Manuscript paper folder, which is where 

the original score was installed. 

 You must keep the same symbol names and notehead style names to allow the plugin to 

find the noteheads. You can, however, replace the definition of the symbols that make 

up the noteheads. For example, I edited the symbol Red Half, which is used in the 

notehead style Red. I imported a different SVG graphic into the symbol and made the 

appropriate scale and position adjustments. I did not change the symbol name. So now 

it uses a colored bordered notehead symbol. I did this for 25*3 symbols to change all the 

notehead colors I support. I did not have to change the notehead style definitions at all 

 Please note that in the data score the symbols for the color White, which was added 

later, are not adjacent to the other colored noteheads. Don’t miss them if you are 

changing symbols. 

 If you want to use the plugins, you have only 25 color names to use as notehead style 

names(in addition to Black, which is the notehead style Normal, not a separate SVG 

color).  
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 You can put any SVG file you want in any of the replaced symbols so you can reuse a 

name for a different color or even shape if your desired color name is not available. 

 

 
If you have created the custom data score and its name starts with Colored NoteheadStyle.sib, and it 
is stored in the For Plug-ins subfolder of the user Manuscript paper folder, then you should see a 
dialog come up when you use Color Enharmonic Pitches and other plugins in the suite, and you can 
choose to use that as your data file. 
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The history of this project, and how things were done 
 
I was answering questions on the Sibelius tech support forum about the Add Notehead Names plugin, 
and Kai Struck kept asking questions about how the notehead styles in that plugin were created. He 
eventually created some SVG graphics to make up solfege noteheads. I was mentioning my frustration 
with coloring of noteheads, and he suggested that SVG noteheads could be used for coloring.  
 
I decided that if we limited ourselves to Normal shapes in the Opus font, and to the named colors I 
use in other plugins, we could get a full set of colors in 25 notehead styles, which would fit in scores 
that did not already have user defined notehead styles. 
 
Kai agreed to create a set of SVG graphics noteheads for the project, and I created symbols using the 
graphics, and then made up notehead styles for all these colors. I created a score that used each of the 
colors (with a quarter, half and whole note for each color) and each color labeled by its name. 
 
My plan was to create house styles using the colors, but I found that when I imported such a house 
style, it could replace the text in the score with whatever was in the score that made the house style. 
So instead I decided to copy notes from the data file I had set up and labeled into other scores. 
 
I was considering how to distribute the data file. I could attach it to a post on the tech forum, but 
those disappear quickly. Then I was playing with the plugin installer, and found that if you put a sib 
file in the zip file on the download page, it will place the sib file in a "For plug-ins" subfolder added to 
the user Manuscript Paper folder. What is curious about this is File >New does not see these files, but 
a plugin can get to them. 
 
I thought that having a plugin create a new score might be a cool mechanism, so I wrote a plugin that 
just created a new score based on that MS Paper, and it worked fine. It would leave a copy of the data 
file open, and you could copy out of it and then close the data file without saving, and the original file 
would not get messed with and corrupted. This became the plugin Colored Notehead Data File. 
 
I then thought that it would be useful to have enough tools available so you could do real work with 
this coloring mechanism. I started incorporating some code to import colored notehead styles into 
existing plugins and realized that it would be simpler to put all this code into a single separate plugin 
that other plugins could call. This became Import Colored Notehead Styles. I adapted the existing 
plugin Color Enharmonic Pitches to use that code, but decided it was too much work to fit the new 
code into old plugins. I wrote some new plugins, Colored Noteheads On Harp Strings and Remove 
Colored Noteheads, and then modified Filter Other to handle these notehead styles. 
 
At this point I figured I had all the code I needed to get work done, and I just needed to document 
everything. And here we are. I hope you enjoy having properly colored chords! 
 


