
Changes in Sibelius 6.1 
The version number of Sibelius 6.1 is Sibelius 6.1.0 build 14. Changes marked with an asterisk (*) denote bugs 
from Sibelius 5 or earlier that are fixed in Sibelius 6.1. Changes marked with a dagger (†) were fixed in Sibelius 
6.0.1. Changes marked with a double dagger (‡) were fixed in Sibelius 6.0.3. (Last updated 3 September 2009.) 

Miscellaneous improvements 
 It is no longer possible to drag a score window behind the toolbar on computers with two displays (Mac 

only). * 

 If you launch Sibelius by double-clicking a score icon, the title bar of the score’s window no longer opens 
underneath Sibelius’s toolbar (Mac only). * 

 If you switch Sibelius’s toolbar on or off via View > Toolbar, any open score windows are repositioned such 
that they do not end up behind the toolbar (Mac only). * 

 If you open a Sibelius score on your second display and maximize it, then drag it right up to the top of the 
display, the score now appears on the screen correctly when it is next re-opened (Mac only). * 

 Sibelius’s memory usage no longer grows unbounded when scrolling through the pages of a large score 
without editing (e.g. during playback). † 

 Sibelius is now a Large Address Aware (LAA) application on Windows. This means that if your computer 
has more than 2GB RAM installed, Sibelius can access more of your computer’s memory, under certain 
circumstances:  

o If you are running 32-bit Windows XP, and have enabled the /3GB switch in boot.ini (see 
http://tinyurl.com/winxpmem), Sibelius can access up to 3GB RAM. 

o If you are running 64-bit Windows XP or Windows Vista, Sibelius can now access up to 4GB RAM. 

Accessing more than 2GB RAM is useful for playback of large scores with many staves, allowing your 
computer to run more channels of sounds simultaneously (Windows only).  

 The performance of Quick Look preview for Sibelius scores on Mac OS X 10.5 and later has been improved. 
Scores now appear more quickly, and the Quick Look window is now correctly resized to match the aspect 
ratio of each score being previewed (Mac only). 

 Sibelius is now compatible with Mac OS X 10.6 Snow Leopard. ‡ 

 When Restore score window sizes and positions is switched on (on the Files page of Preferences), if 
you open one score and maximize it, further scores that you open are no longer incorrectly also opened 
maximized (unless they were previously saved maximized) (Mac only). * 

 Toggling the zoom state of one score when another score is minimized to the Dock no longer causes that 
minimized score to be incorrectly restored from the Dock (Mac only). 

 When using Ctrl+mouse wheel or Command-mouse wheel to zoom, the rate of zoom is now visually the 
same as you zoom in and out, rather than appearing to slow down as you zoom further and further in. 

 If you are running a version of Sibelius localized in one language with a serial number intended for a 
different language version of Sibelius, Sibelius will now warn you each time it starts up. This is important 
because some features do not work correctly if the language of the program and the language of the serial 
number do not match. 

 On-screen anti-aliasing has been improved for many objects at particular zoom levels, including slurs, 
noteheads, piano braces, etc. (Windows only). 

 A problem whereby Sibelius can sometimes show an error Can not find or initialize PlogueEngine 
dll/bundle on start-up has been fixed (Windows only). * 

 Some preferences are now stored more efficiently, reducing the amount of time taken to write them, which is 
important on 64-bit Windows, where Registry settings for 32-bit applications are always written into two 
places in the Registry. * 
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 If you enter a title on the Score Info page of File > New that consists entirely of characters that are not 
permitted in Windows filenames, e.g. ? ! * / etc., Sibelius will no longer prevent you from saving the score 

 When switching between scores, the Create > Text > Lyrics menu now correctly updates itself according to 
the text styles in the score. 

 If you attempt to open a score from the Finder while Sibelius is showing a dialog (e.g. File > Quick Start), 
Sibelius no longer opens the score, leaving the program in an inconsistent state. * 

 Some improvements to the built-in Spotlight importer, to prevent it from crashing (Mac only). 

 Font installation is now handled in a different way on Mac: instead of the fonts being located inside the 
Sibelius application package and being copied to the user-level Fonts folder when Sibelius runs, Sibelius's 
required fonts are now installed to the system-level Fonts folder by the Sibelius 6 installer package. This 
solves a problem whereby Sibelius is unable to successfully activate its fonts when it runs for the first time 
(Mac only). 

 A problem whereby the Create > Line, Create > Key Signature and Create > Clef dialogs did not create the 
expected object has been fixed (Mac OS X 10.6 Snow Leopard only). ‡ 

1.1 Note input 
 The rest button on the Keypad now correctly switches itself off after inputting a rest using the mouse. 

 The initial volume used by Sibelius when clicking on a note in the score, or inputting a note via the 
Keyboard or Fretboard windows, before the score has been played back is now correct. † 

 When auditioning a sound via MIDI thru (i.e. select a note or bar on a staff, hit Esc, and play on your MIDI 
keyboard), Sibelius now correctly takes into account the prevailing instrument change at the position you 
selected, so that it will use the correct sound. 

 When Sibelius creates extra bars during step-time input in a staff that contains at least one instrument 
change, the first note of each newly-created bar no longer sounds with the wrong sound. 

 Deleting the last rest in a tuplet no longer causes a crash when a score contains multiple staves (Windows 
only). 

1.3 Keyboard window 
 Middle C (C4) is now labeled in the Keyboard window.  

 When following the score during playback, notes in tuplets no longer appear to overlap on the Keyboard 
window. 

1.5 Scanning 
 Key signatures in scores created by importing from PhotoScore and AudioScore are now correctly created 

for the entire system, so that any new instruments added to the score after import will inherit the existing 
key signature. * 

 Chord symbols that are not recognized are no longer always imported from PhotoScore and AudioScore at 
the start of the bar in which they appear. 

 1st- and 2nd-ending lines are no longer incorrectly imported from PhotoScore files attached to a particular 
staff rather than to the system. * 

1.8 Fretboard window 
 It is now possible to click on the Fretboard window to hear pitches without entering notes in the score (i.e. 

MIDI thru). 

1.9 Selections and passages 
 The keyboard shortcuts for navigating between notes and chords in different voices and on different staves 

have been thoroughly revised, as follows: 
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o Alt+3/2 selects the next highest or lowest note in the chord. If the highest or lowest note of the chord 
is selected, typing Alt+3/2 selects any tremolos on the stem (if present), typing Alt+3/2 again 
selects the handle at the end of the stem (if the stem is pointing in that direction), and typing it again 
selects the articulation nearest to the note, if any are present. 

o Shift+Alt +3/2 selects the highest or lowest note in the next used voice (so if you have selected, for 
example, the bottom note of a chord in voice 1 and type Shift+Alt +2, Sibelius will select the highest 
note in voice 2, if present; if not, the highest note in voice 3, or voice 4). 

o Ctrl+Alt+2 selects the highest pitch or rest in the lowest numbered voice on the staff below; 
Ctrl+Alt+3 selects the lowest pitch or rest in the highest numbered voice on the staff above. 

If there is no note or rest at the same rhythmic position in the next voice or staff, Sibelius will select the note 
or rest at the nearest rhythmic position earlier in the same bar. Voices that are not present are simply 
skipped, and when moving between staves, hidden staves are likewise skipped.  

 Navigation left and right through notes and chords, accidentals, articulations, ties and rhythm dots, by 
typing Alt+0/1, has also been improved. The order of selection from left to right when typing Alt+1 is now 
as follows: 

o Arpeggio line 

o Scoop or plop 

o Accidental 

o Notehead 

o Rhythm dot 

o Fall or doit 

o Tie left-hand end 

o Tie 

o Tie right-hand end.  

Sibelius attempts to select the note nearest in chromatic pitch to the last-selected note when hopping the 
selection between notes left and right. 

 When you select notes, the rules for which notes are sounded via Play notes as you edit (on the Note input 
page of Preferences) have been improved, as follows:  

o 0/1 plays all of the notes in the chord in that voice, so that moving through notes and chords on a 
staff quickly allows you to hear the selected note in context. 

o Alt+0/1 plays only the selected notehead. 

o Alt+3/2 plays only the selected notehead. 

o Clicking on a single notehead within a chord now plays only that note; double-clicking a selected 
chord plays all of the notes in that chord. 

o Ctrl+click or X-click to select multiple notes within a chord now plays only the selected notes. 

o Adding or removing an accidental (either by deleting a selected accidental, or by adding one from the 
Keypad) now plays the affected note. 

o If you would prefer Sibelius to play the whole chord when selecting any note of a chord, rather than 
the new behavior of playing only the selected note, switch on Play all notes in chord when any note 
selected on the Note Input page of Preferences. 

 Sibelius no longer crashes when pasting material at the start of a score where the first item in the top staff of 
the selection would need to be pasted before the start of the first bar. † 

 Moving an object immediately after copying it without first moving the mouse now causes the object to re-
attach to new rhythmic positions correctly. 
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 When copying from a score that uses user-defined instrument types, those user-defined instrument types are 
only copied to the destination score if they end up getting used in the pasted selection. This helps to reduce 
style “bloat” when copying and pasting between scores. * 

 Under some circumstances Sibelius can crash when selecting an object by clicking on it. This problem has 
now been fixed. † 

 A problem whereby aftertouch messages received during step-time input could result in some notes getting 
lost has been fixed (Mac only). * 

 Sibelius no longer crashes if you attempt to paste a system passage at the start of the score after selecting the 
initial systemic barline. * 

1.10 Input devices 
 Sibelius now supports MIDI Machine Control (MMC), which is a standard way for hardware input devices 

to specify playback controls such as start, stop, fast-forward, rewind, etc. If your input device supports 
MMC, you can now use it to control the Playback window in Sibelius. 

 New Record system exclusive messages checkbox on the Input Devices page of Preferences, switched 
on by default. Switch this checkbox off if you find that your audio drivers do not correctly release the buffer 
required to record system exclusive MIDI messages and hence do not allow Sibelius to exit cleanly. 

1.11 HyperControl™  
Sibelius is now compatible with HyperControl, the MIDI mapping technology used in M-Audio Axiom Pro 
controller keyboards. HyperControl automatically maps the knobs, faders, drum pads and numeric keypad 
buttons on the keyboard to playback, Mixer and note input controls in Sibelius, via a two-way link that ensures 
the keyboard’s controls are always in sync with the settings in Sibelius. The Axiom Pro’s LCD display 
constantly updates to show the current values, to ensure seamless editing and prevent parameter jumps. 

Enabling HyperControl 

Before you work with HyperControl in Sibelius, you must install the drivers supplied with your Axiom Pro 
keyboard. Please follow the driver installation instructions found in the printed Quick Start Guide that was 
supplied with your keyboard. 

To enable HyperControl in Sibelius: 

 Choose File > Preferences (in the Sibelius menu on Mac) and go to the Input Devices page. 

 You will see four devices corresponding to your Axiom Pro keyboard. To enable regular MIDI input, switch 
on the Use checkbox for the Axiom Pro USB A In device; notice that the Input Map column is automatically 
set to Axiom Pro 49+61 or Axiom Pro 25 as appropriate. To enable HyperControl, switch on the Use 
checkbox for Axiom Pro HyperControl In; the Input Map column is automatically set to M-Audio 
HyperControl. (On Mac OS X 10.4 Tiger, Axiom Pro USB A In will appear as Axiom Pro Port 1, and Axiom 
Pro HyperControl In will appear as Axiom Pro Port 2.) 

 Click OK. 

Using HyperControl 

HyperControl uses the buttons, sliders and knobs on the Axiom Pro, as shown in the picture below: 
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(This picture shows the controls on the Axiom Pro 49; the Axiom Pro 61’s controls are identical, while the 
Axiom Pro 25 does not include the sliders, slider buttons, master fader, or Flip button.) 

The buttons perform the following functions: 

 Using the numeric keypad, you can access most of the functions of Sibelius’s on-screen Keypad, for note 
editing and step-time input. The numbers are arranged in the opposite order to the numeric keypad on a 
regular computer keyboard, so hitting 9 on the Axiom Pro is equivalent to hitting 3 on your computer’s 
keypad, hitting 1 on the Axiom Pro is the same as hitting 7 on your computer’s Keypad, and so on. Switch 
between Keypad layouts by hitting – on the Axiom Pro. + is equivalent to the . (period) key on your 
computer’s numeric keypad (e.g. for adding rhythm dots). 

 The soft-keys perform the function shown above each on the LCD display directly above them. 

 The F-keys act as follows: 

o F1 (labeled Mode) switches between the two main HyperControl modes, Mixer and Selection. 

o F2 and F3 (labeled Track) select the previous or next Mixer strip in Mixer mode, or select the previous 
or next staff in Selection mode. 

o F4 (labeled Mute) mutes and unmutes the selected Mixer strip in Mixer mode. 

o F5 (labeled Solo) solos and un-solos the selected Mixer strip in Mixer mode. 

o F6 and F7 (labeled Bank) move the selection by eight strips in Mixer mode, or by eight staves in 
Selection mode. 

 The sliders allow you to adjust the volume faders in the Mixer, either for individual staff strips, or group 
strips. 

 The master fader always adjusts the master volume level in the Mixer. 

 In Mixer mode, the encoder knobs allow you to adjust additional parameters for staves in the Mixer; in 
Selection mode, the encoder knobs allow you to navigate a bar or a page at a time, or zoom in and out. 

 The transport buttons act as you would expect. Hold the Loop button with Rewind to move the playback 
line to the start of the score, and hold Loop with Fast-forward to move the playback line to the end. 

 The drum pads map to the standard General MIDI drum mapping and can be used to input drum kit 
notation, if the option for percussion staves is set to The MIDI device’s drum map on the Note Input page of 
Preferences. Hold down the two Peek buttons (to the right of the soft-keys) to display the pad mapping on 
the Axiom Pro’s display. 

Mixer mode 

In Mixer mode, the four soft-keys are labeled Home, Pan, Param and Group. You will also see the name of the 
score currently open in Sibelius on the Axiom Pro’s display. 

By default, moving the sliders will adjust the volume of the first eight staves in the score. Notice how the Axiom 
Pro’s display shows no change until the physical slider on the keyboard matches the position of the 
corresponding fader in the Mixer: this is known as a soft take-over, and ensures that you do not hear a sudden 
volume change when you start to adjust the volume. Press the Group soft-key to map the sliders onto the faders 
for group strips in the Mixer. To return to adjusting the volume of individual staves, press the Level soft-key, 
which becomes the label for the fourth soft-key when in Group mode. 

You can mute or solo a particular staff or group by pressing F4 and F5 respectively, according to whether you 
are in Level or Group mode. To show the volume or group levels for the next bank of eight staves or groups, 
press F7; to move back to the previous bank, press F6. 

By default, the encoder knobs adjust the panel levels of the first eight staves in the score. Press the Param soft-
key to map the first six encoder knobs onto the additional Mixer parameters for sounds played back by the 
Sibelius Player instead: the Axiom Pro’s display shows which staff’s parameters are being edited, and the name 
of each parameter along with its current value. The final two encoder knobs are mapped onto the Reverb and 
Chorus controls respectively. To show the next staff’s parameters, press F3; to show the previous staff’s 
parameters, press F2. 
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Selection mode 

To enable Selection mode, press F1: the display will show the function of each of the encoder knobs. To select a 
staff, press the corresponding slider button (e.g. to select the top staff in the system, press the slider button 
below the first slider). You can press another slider button to select a different staff, or hop the selection to the 
staff below with F3 or the staff above with F2. To extend the selection to include the staff below, turn the fourth 
encoder knob to the right; to remove a staff from the selection, turn it to the left. 

By default, Sibelius selects the first bar on the page that is closest to the center of the view: the Axiom Pro’s 
display will show the name of the selected staff, and the bar number at the start of the selection. To select the 
next bar, turn the second encoder to the right, and to select the previous bar, turn it to the left. To select the first 
bar on the next page, turn the third encoder to the right, and to select the first bar on the previous page, turn it 
to the left. 

The fifth encoder scrolls the view up/down (equivalent to Page Up/Page Down), and the sixth encoder 
zooms: turn to the right to zoom in, and turn to the left to zoom out. 

You can use the numeric keypad on the Axiom Pro for note input when in Selection mode: simply select the bar 
in which you want input to begin, hit the appropriate button on the keypad, and start playing notes and chords 
on the MIDI keyboard. 

To start Flexi-time input, select the bar in which you want input to begin, and extend the selection to the staff 
below by turning the fourth encoder to the right: then hit the record button on the Axiom Pro’s transport 
controls to start recording. 

Leaving HyperControl mode 

When Sibelius exits, the Axiom Pro is reset back to its default, non-HyperControl mode. 

2.1 Accidentals 
 Sibelius will no longer incorrectly show automatic cautionary accidentals on repeated notes within the same 

bar when Restate accidentals when seen in a new voice is switched on. 

2.2 Arpeggios 
 Squiggles in note-attached arpeggio lines on grace notes and normal notes adjacent to one another now 

appear at the correct size. 

 2.3 Articulations 
 Sibelius now accommodates the convention whereby if a staccato is combined with another articulation on 

the same side of the note, the pile of articulations should be centered on the notehead, even when it is on the 
stem side. This is achieved by way of two new checkboxes that provide exceptions to the standard Center 
staccatos on stem rule:  

 
Switching on at same end means that staccatos will be centered on the stem, except when they are 
combined with other articulations that appear on the same side of the note as the staccato (e.g. beats 2 and 3 
in the above examples), in which case they will be centered on the notehead. 

Switching on at opposite end means that staccatos will be centered on the stem, except when they are 
combined with other articulations that appear on the opposite side of the note as the staccato (e.g. beats 1 
and 4 in the above examples), in which case they will be centered on the notehead. 

The two common conventions are to always center other articulations on the stem when a staccato is present, 
on either the same or opposite sides of the note (Sibelius’s default), or to always center other articulations on 
the notehead even when a staccato is present on either the same or opposite sides of the note (which is 
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achieved by choosing Center staccatos on stem and switching on both the exceptions for other 
articulations at same end and at opposite end).  

 Where an articulation is on the opposite side of the note to a staccato marking, that articulation is now 
always centered on the notehead. 

 A new row of checkboxes has been added to the Articulations page of House Style > Engraving Rules, 
allowing you to determine which articulations should go within the curvature of a slur and which should go 
outside. These new checkboxes, labeled …inside middle of slur act as counterparts to the existing …inside 
slur checkboxes, now renamed as …inside start or end of slur. 

These checkboxes only take effect if Layout > Magnetic Layout is switched on, and if slurs are set to 
automatically avoid collisions with objects under their arcs. 

In existing scores, all of these checkboxes are switched on, to maintain as closely as possible the behavior of 
previous versions of Sibelius. In newly-created scores, all articulations except for the upbow, downbow and 
fermatas (pauses) are allowed within the curvature of the slur. 

In cases where both a slur and a tuplet are present, the settings prescribed by the …inside tuplet row of 
checkboxes will take precedence over the …inside middle of slur settings, because tuplets are typically 
closer to notes than slurs and therefore should have a naturally higher priority.  

 New Allow articulations below the middle of a tuplet bracket to be split checkbox on the Articulations 
page of House Style > Engraving Rules. This option is switched off in existing scores, and switched on in 
newly-created scores. When this option is switched on, Sibelius will allow those articulations that have the 
corresponding …inside tuplet checkbox switched on to appear inside the middle of a tuplet bracket (i.e. not 
on the first or last note of a tuplet bracket). This corrects a number of problems where, for example, an 
upbow on the first note of a tuplet would be positioned outside the tuplet bracket, but a downbow on the 
next note of the tuplet would be positioned inside (or colliding with) the tuplet bracket. 

 When Magnetic Layout is switched on, articulations are now allowed to move vertically in order to avoid 
collisions with ties and accidentals. You can also switch off Magnetic Layout for a pile of articulations above 
or below the note by selecting them and choosing Edit > Magnetic Layout > Off, or freeze their Magnetic 
Layout position by choosing Layout > Freeze Magnetic Layout Positions.  

 Articulations that were flipped below the staff on a tab staff in the attached Sibelius 4 score now appear 
above the staff in Sibelius 6. 

2.10 Chord symbols 
 Sibelius now supports chord symbols that consist only of a slash and an altered bass note. This is a 

commonly-used shorthand denoting that the previous chord symbol continues, but the bass note changes. 

o To create such a chord symbol, simply type e.g. /F# as the chord symbol, and Sibelius will 
automatically work out what the chord is based on the previous chord symbol. 

o To hide or show a chord’s root and type, choose Edit > Chord Symbol > Add/Remove Chord Text 
Root. 

 It is now possible to specify that an individual instrument type (e.g. bass guitar) should not show chord 
diagrams even when they are set to display in Engraving Rules. You can switch off Show guitar chord 
diagram by default for any instrument type in the New/Edit Instrument dialog. 

 New After numbers checkbox below the Use # / b alterations radio button on the Chord Symbols page of 
Engraving Rules, which allows you to show e.g. 9b or 11# instead of b9 or #11 in chord symbols. 

 Chord symbols can now be made left-aligned on noteheads rather than using the default centered alignment. 
To change this: 

o Choose House Style > Edit Text Styles 

o Select the Chord symbol text style 

o Click Edit, and go to the Horizontal Posn tab 

o Choose Left from the Align to note options, and click OK 
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o Sibelius will tell you that the default position of chord symbols should also be adjusted, and offer to 
do this for you: click Yes to let Sibelius do this for you now. 

Should you choose not to have Sibelius change the default positions for you, you will need to do this 
yourself: 

o Choose House Style > Default Positions, and choose the Text radio button 

o Select Chord symbol in the list at the left-hand side 

o Set Horizontal position relative to note n spaces to 0 for both Score and Parts 

o Choose the Other objects radio button 

o Select Chord Symbol in the list at the left-hand side 

o Set Horizontal position relative to note n spaces to 0 for both Score and Parts 

o Click OK. 

Newly-created chord symbols will thereafter be left-aligned, but existing chord symbols in your score will 
not become left-aligned until you select them and choose Layout > Reset Position. 

 In bars where there are few or no notes, chord symbols now snap to appropriate rhythmic positions when 
dragged left and right through the bar. 

 Note that some chord symbols using new, improved suffix appearances (see 8.13 Edit Chord Symbols 
below) may not appear the same when the score is opened in Sibelius 6.0 or Sibelius 6.0.1. To ensure that 
chord symbols appear the same when sharing files with other Sibelius users, it is strongly recommended that 
all parties who are sharing files update to Sibelius 6.1. 

 Typing (say) C2 or C4 for chord symbol input will now correctly be recognized as Cadd2 or Cadd4. 

 The Text input name for a chord symbol can now begin with a lower-case “b” if required. 

 Sibelius now automatically switches to Roman alphabet input when inputting chord symbols if using an 
Input Method Editor set to another script, e.g. Japanese. 

 Chord diagrams with custom chord names created in earlier versions of Sibelius now correctly transpose in 
Sibelius 6 and Scorch 6 when the score is transposed. 

2.11 Clefs 
 New sub-bass F clef, which is like a normal bass clef positioned on the top line of the staff, with pitches two 

octaves below a treble clef. 

 Create > Clef now includes a read-out of the name of the selected clef.  

 Deleting a clef on one page now always ensures that the clef at the start of the next system on the following 
page updates immediately, without requiring the next page to be edited or redrawn. 

2.15 Guitar notation and tab 
 The default shape of bend lines on notation staves is now much improved by default. * 

 It is now possible to adjust the position of the mid-point of bends on notation staves, making it possible to 
change their angle individually.  

 Guitar bend lines now show handles when selected or when View > Handles is switched on.  

 The positions of the end points of bends on both notation and tab staves on either side of a system or page 
break can now be edited independently.  

 When a bend crosses a system or page break, Sibelius ensures that the continuation of the bend on the new 
system starts above the tab staff, so it’s easy to see.  

 Guitar bends no longer flip incorrectly over page breaks. * 
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2.16 Guitar scale diagrams 
 The default scale diagrams for G major pentatonic are no longer incorrect. 

2.18 Instruments 
 When instrument changes are made cue-sized, any music text font characters in the instrument change text 

are now spaced correctly (Windows only). * 

 The transpositions of the Wagner Tuba in Bb and Wagner Tuba in F instruments have been corrected in 
newly-created scores. * 

 Creating an ossia staff with a system selection no longer causes Sibelius to crash. * 

 An obscure problem whereby instrument changes at the start or end of an ossia could not always be dragged 
to the end of the system has been fixed. * 

2.20 Key signatures 
 Creating a key signature in a dynamic part no longer causes Sibelius to crash. † 

2.21 Lines 
 Create > Line (and House Style > Edit Lines) now includes a read-out of the name of the selected line.  

 Non-magnetic lines no longer perform the look-ahead associated with the new slur direction rule for 
magnetic slurs, resulting in a small performance increase in scores with many lines. † 

2.23 Manuscript paper 
Changes to some manuscript papers: 

 Concert band: revised substantially. 

 Concert band, small: revised substantially. 

 School band 9-12: changed Bass Clarinet and Baritone Sax to use bass clef in concert pitch, treble clef in 
transposed pitch; switched Notes > Transposing Score on; moved trumpets above horns. 

 School band 6-8: changed Baritone saxophone to use bass clef in concert pitch, treble clef in transposed 
pitch; switched Notes > Transposing Score on. 

 Orchestra, Romantic: changed bass clarinet to use bass clef in concert pitch, treble clef in transposed pitch. 

 Marching band 1: changed baritone saxophone to use bass clef in concert pitch, treble clef in transposed 
pitch. 

 Big band: changed baritone saxophone to use bass clef in concert pitch, treble clef in transposed pitch. 

 Brass band: switched on Notes > Transposing Score. 

2.25 Noteheads 
 Slash noteheads now correctly remain in the same position when Notes > Transposing Score is switched on 

and off for instruments that use different clefs at sounding and transposed pitch. 

2.27 Repeat bars 
 New Number 2-bar repeat bars and Number 4-bar repeat bars checkboxes on the Bar Rests page of 

House Style > Engraving Rules, switched off by default. When switched on, Sibelius replaces the bold 2 or 
4 digits above 2- and 4-bar repeats with numbers that show how many times the bars are repeated, 
analogous with the existing option to number 1-bar repeats.  

 New Count repeat structures when numbering repeat bars, and show as checkbox on the Bar Rests 
page of House Style > Engraving Rules, switched off by default, and only available if any of the options to 
number repeat bars are switched on. This option allows you to show the actual number of repetitions of a 
series of repeat bars in a passage that is itself repeated (by way of repeat barlines). When switched on, 
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Sibelius shows a number corresponding to each repetition of the 1-, 2- or 4-bar repeat in the repeat structure. 
This option only takes effect if repeats are enabled for playback in Play > Repeats.  

 The Special barlines checkbox on the Bar Rests page of House Style > Engraving Rules has been 
renamed as Double barlines, and repeat bar numbering is now only reset after double barlines, and not 
other kinds of special barlines (e.g. start repeat barlines).  

 Tremolos in unpitched percussion staves no longer play back more loudly in repeat bars when played back 
from the repeat bar than when played back from the bar in which the repeated notes first occur. 

2.28 Slurs  
When Magnetic Layout is switched on, magnetic slurs now automatically avoid collisions with objects under 
their arc – e.g. notes, accidentals and articulations – by changing their shape and moving their end points 
automatically to find the best fit. 

This behavior is automatically enabled in new scores created in Sibelius 6.1, and when you open scores created 
in versions of Sibelius prior to Sibelius 6, switching on the Use Magnetic Layout checkbox in Update Score 
will also enable collision avoidance for slurs. When you open a score created in Sibelius 6.0 in Sibelius 6.1, you 
will be asked whether you want to enable collision avoidance for slurs: if you click Yes, Sibelius will also ensure 
various other options in Engraving Rules are switched on, so that the collision avoidance will work correctly. 

To disable collision avoidance for all slurs in your score, choose House Style > Engraving Rules, go to the 
Slurs page, and switch off Adjust shape to avoid collisions under arc.  

To disable collision avoidance for an individual slur, select it and switch off the Avoid collisions under arc 
checkbox on the Lines panel of Properties. Such a slur will not allow other objects (e.g. text, lyrics, lines, etc.) to 
collide with it, but it will itself not adjust its shape to avoid collisions with notes etc. under its arc. To make a 
slur completely oblivious to collisions of any kind, select it and choose Edit > Magnetic Layout > Off. If you find 
yourself using the Avoid collisions under arc checkbox in Properties often, you can assign a keyboard 
shortcut to it in the Edit category on the Menus and Shortcuts page of Preferences. 

The frame that appears around a selected slur will be colored red if Avoid collisions under arc is switched off 
for a particular slur. Non-magnetic slurs (which are colored red when selected) cannot avoid collisions with 
other objects, and so will always show a red frame. If Magnetic Layout is switched off altogether, or if the 
Adjust shape to avoid collisions under arc option in Engraving Rules is switched off, all slurs will show a 
gray frame when selected. 

You can still adjust the position of a slur’s end points and adjust its shape when it is set to avoid collisions in the 
usual way: Sibelius will use your positioning choices as a hint to help it make the most pleasing shape. You can 
determine how Sibelius chooses to adjust slur shapes by default using the new options in Engraving Rules: 

 Minimum gap around slurs n spaces determines how close to objects under their arc slurs should be 
positioned. 

 Move ends if slur exceeds n spaces high determines the height of the slur beyond which Sibelius will 
prefer to move the end points rather than increase the curvature in order to avoid a collision. Increase this 
value to allow more steeply curved slurs, and reduce it for more gently curved arcs; to force Sibelius never to 
move the end points unless absolutely unavoidable, set this to a very high number (e.g. 20 spaces). 

 The slider allows you to balance the movement of the end points versus changing the curvature of the slur; 
try out different values to see what you prefer. 

 Make ends level when slur is shorter than n spaces determines the maximum length of slur for which 
Sibelius should force the end points to be horizontal if the first and last notes under the slur are at the same 
staff position. 

Other improvements to slurs in Sibelius 6.1: 

 Dotted and dashed slurs no longer show spurious extra handles a long way away from the lines themselves 
when selected. 

 At zoom levels of 300% and greater, using the arrow keys to adjust the height of a slur now works correctly. 
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 A problem whereby slurs in scores created in certain previous versions of Sibelius would be erroneously 
converted to guitar bends when opening the score in Sibelius 6 has been fixed, and any scores that exhibit 
this problem are fixed up when opened in Sibelius 6.1. 

 Switching on Slur left curve or Slur right curve on the Lines panel of Properties for a slur on a small staff 
no longer incorrectly changes the shape of the slur. 

2.29 Staves 
 Changing the thickness of staff lines etc. in Engraving Rules now updates the score display immediately, 

rather than waiting until after you make an edit that forces a redraw. 

2.30 Stems and leger lines 
 The default width of leger lines on half note (minim), whole note (semibreve) and bar rests has been 

improved. Furthermore, a new Leger lines extend beyond rest by n% of its width option on the Notes 
and Tremolos page of House Style > Engraving Rules now allows precise control over the width of leger 
lines on such rests.  * 

2.32 Ties 
 Hitting Esc to deselect the handle at the start of the second half of a tie after a system break now correctly 

updates the visual appearance in the score. 

 Restoring the default position of ties with Reset Position now updates the score immediately, without 
requiring you to force a redraw. 

2.35 Triplets and other tuplets  
Tuplet numbers and brackets are now positioned above notes by default, unless all of the stems of the notes in 
the tuplet point downwards, or if the implied beam encompassing the notes in the tuplet would force the stems 
to point downwards. 

This new rule is enabled by setting the radio button Position tuplets as if all notes were beamed together on 
the Tuplets page of House Style > Engraving Rules. This rule is used in newly-created scores, but is not used 
in existing scores (to avoid changing their appearance). 

The positions of the ends of tuplet brackets relative to the first and last notes of the tuplet have also been 
overhauled: 

 The old Full duration option in the Create > Tuplet dialog has been replaced by a pair of radio buttons. 
Extend to first note after tuplet is the new name for the old Full duration option, and the default option is 
now called Extend to last note in tuplet. 

 It is now possible to switch the duration of an existing tuplet between Extend to last note in tuplet and 
Extend to first note after tuplet using a drop-down in the Notes panel of Properties. 

 The Horizontal distance from note control on the Tuplets page of House Style > Engraving Rules has 
been replaced with four new controls that allow you to specify the position of the left- and right-hand ends 
of tuplet brackets more precisely: 
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In the image above, n spaces from head of first note and n spaces from head of last note are both set to 
0.5 spaces for illustrative purposes; by default, both these settings are set to 0 spaces, because conventionally 
tuplet brackets are aligned with the edge of the notehead. The n spaces from stem of first note and n 
spaces from stem of last note are set to 0.5 spaces by default (the same value as shown above), to avoid 
the hook of the tuplet bracket at the stem end appearing to run into the stem. 

The new n spaces from first note after tuplet control allows you to specify how far from the next note after 
the tuplet the tuplet bracket should end, when using the Extend to first note after tuplet duration option. 

Finally, the behavior of auto-brackets for tuplets has been improved. A new Hide tuplet bracket when notes 
joined by secondary beam option has been added to the Tuplets page of House Style > Engraving Rules. 
This option is switched off by default. When switched on, and when a tuplet is using an auto-bracket, Sibelius 
will now hide the bracket when: 

 the entire tuplet is contained within the beam; 

 the last note before the start of the tuplet must be an eighth note (quaver), or the first note of the tuplet must 
have the Start secondary beam option set via the Keypad; 

 the first note after the tuplet must be an eighth note (quaver), or must have the Start secondary beam 
option set; 

 all of the notes in the tuplet must be the same or shorter in duration than the first and last notes of the tuplet, 
and none may have Start secondary beam set. 

When tuplets are flipped, the tuplet number is now correctly centered within the tuplet bracket. 

3.1 Working with text 
 The Word Menus page of Preferences has been improved. Instead of displaying the plain text equivalents 

of each of the words in Sibelius’s word menus, the words are now displayed as they appear in the word 
menus themselves. Because of this change, the Apply button now applies to both the Text and Shortcut 
fields (in previous versions it applied only to the text field), so don’t forget to click Apply after changing the 
keyboard shortcut for a word menu item.  

 Clicking Cancel in the Preferences dialog after changing one or more word menu items now correctly 
undoes the changes made to word menus in that dialog session. * 

 Sibelius now measures PostScript (Type 1) fonts at a single zoom level; unfortunately Windows is unable to 
measure PostScript fonts accurately, and you are recommended to use TrueType fonts wherever possible 
(Windows only). 

 Deleting page-aligned text (e.g. headers) no longer leads to Sibelius crashing. 

 Text objects beginning with many carriage returns no longer appears with the wrong line spacing and in the 
wrong place vertically on the page (Mac only). 

 Fonts that may have previously appeared with trailing hyphens in the various menus in which font names 
appear in Sibelius will no longer show trailing hyphens (Mac only). 
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3.3 Lyrics 
 The Allow first syllable to overhang barline option in House Style > Note Spacing Rule now works as 

expected once more. † 

 Lyric hyphens between syllables no longer appear a tiny bit further to the right than they did in Sibelius 5 
and earlier. † 

 The “inner” handles on lyrics that cross a system or page break now appear correctly once more. 

3.7 Rehearsal marks 
 Deleting a rehearsal mark in one system now correctly updates the appearance of rehearsal marks in 

subsequent systems without requiring the user to force a redraw. 

4.1 Working with playback 
 Sibelius no longer hangs when you start playback if a trill line overlaps one or more grace notes attached to 

the end of a bar. 

 Closing a dynamic part’s window no longer unnecessarily unloads all the sounds loaded into Sibelius 
Player. 

 The default playback volume for sustaining instruments (e.g. wind, brass, strings) is now correct for staves 
that use voices other than voice 1, in those rare situations where voice 1 is not present. 

 The default playback volume for sustaining instruments is also improved where there are no explicit 
dynamics, and Espressivo is switched off. 

 A problem whereby having a negative start time for a score’s timecode (in Play > Video and Time > 
Timecode and Duration) could affect the dynamics of notes after the start of the score has been fixed. 

 Sibelius now correctly restarts playback from the start of the score if the playback line is positioned at the 
end of the score, and the final note of the score has a fermata (pause). 

 The playback line (and hence the Keyboard and Fretboard windows) now updates more reliably when 
moving note to note; however, the playback line will not move between notes shorter than 16th notes 
(semiquavers), in order to avoid causing playback delays caused by too frequent updates. 

 The position of the playback line and the timecode display on the Playback window now correctly takes into 
account any automatic latency compensation introduced in order to match the playback of multiple virtual 
instruments with different latencies. 

4.2 Interpretation of your score 
 If a fermata is set to produce a gap after the pause and is followed by repeated notes, the second of the 

repeated notes will now sound correctly. 

 Hairpins are now correctly considered when starting playback from the middle of a score. 

4.3 Mixer 
 The volume level for Sibelius Player (and other virtual instruments) is now correctly restored if Sibelius has 

to switch to the playback configuration used by a score when the score is opened. 

 It was possible for Mixer redraws to cause a crash under some obscure circumstances; this bug has now been 
fixed (Mac only). † 

 Sibelius no longer marks a score as dirty if it has to change which categories of Mixer strips are visible when 
opening the score. 

 Sibelius no longer sometimes crashes when switching between scores with the Mixer visible. 

 Clicking the speaker icon in a staff strip to audition a sound now correctly sends the appropriate controllers 
to ensure that the sound can be heard (e.g. for sustaining instruments in Sibelius Sounds Essentials, which 
require a modulation controller message to be sent in order to produce a default volume). 
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4.4 Sibelius Sounds Essentials 
A number of minor improvements to the sounds in the Sibelius Sounds Essentials library: 

 The Harpsichord 8' patch is no longer incorrectly velocity sensitive. 

 The default timbre values for the ensemble string patches has been reduced. 

 The balance of the bass drum roll in the VDL concert percussion patch has been improved. 

4.6 Repeats  
The old Play repeats checkbox in Play > Performance has been moved to a new Play > Repeats dialog, which 
now has the following options: 

 Don’t play repeats: when this option is chosen, Sibelius will ignore all repeats in the score (the equivalent of 
switching off the old Play repeats option). 

 Automatic repeats playback: when this option is chosen (as it is by default in new scores), Sibelius will 
play back repeats in the score according to its own automatic interpretation of repeat barlines, 1st- and 2nd-
ending lines, and jump instructions such as D.C. al Coda. (This is the equivalent of switching on the old Play 
repeats option.) 

 Manual repeats playback: when this option is chosen, Sibelius will play back the bars in the score in the 
order specified in the text control below. This allows you to specify the exact order in which the bars in the 
score are played back by typing ranges of bar numbers in a comma separated list. Sibelius displays the 
current automatic playback sequence to get you started, and you can go back to the automatic sequence by 
clicking Restore Default Order. This is useful for complex repeats sequences that cannot be played back 
automatically (e.g. songs with more than one coda). If you have multiple songs, pieces or movements within 
the same score, leave a blank line between each set of bar numbers corresponding to a single song, piece or 
movement to tell Sibelius to play a gap there. 

When Automatic repeats playback is chosen, you can also switch on Play repeats after a D.S. or D.C. jump, 
which is switched on by default in newly-created scores (but switched off in existing scores to avoid changing 
their playback). When switched on, Sibelius will play back all the previous repeats in full following a D.S. or 
D.C. jump, rather than always taking the last time ending after a jump as in previous versions. 

Sibelius’s handling of nth-ending lines has also been improved. In previous versions, it was necessary for the 
last time ending in any repeat structure to have an open right-hand end (i.e. no vertical line at the right-hand 
end of the bracket). Failure to use an appropriate last time ending line could result in a number of problems in 
playback (e.g. infinite repeats, bar numbers disappearing and bars not playing, or subsequent nth-ending lines 
getting skipped). Sibelius is now forgiving of these situations, and now interprets any nth-ending line as a last 
time ending line if it is not followed in the next bar by another nth-ending line (with an open right-hand end). 

System text instructions of the form Play n times no longer incorrectly apply to all subsequent repeated 
sections; they now apply only up to the next end repeat barline. 

4.7 Live Tempo  
It is now possible to specify tap points that help Sibelius interpret your conducting. By marking in the score 
where you are going to tap, you can employ complex conducting techniques such as melded beats (where the 
conductor combines two or more time-beating gestures into one long sustained gesture that has a duration 
equal to the combined beats). 

Adding and removing tap points 

The quickest way to add tap points is to find the staff with the rhythm you want to tap, make a passage 
selection around that passage (be sure that the staff with the rhythm you want to tap is the top staff in the 
selection), and choose Play > Live Tempo Tap Points, which shows this dialog: 
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 Add tap points or Remove tap points determines whether the options set below in the dialog will add or 

remove tap points from the selection or the whole score. 

 The Range of Operation options determine in which bars tap points will be added or removed: 

o If you had a selection when you chose to open the dialog, it will default to Use rhythm of top staff of 
selection. Sibelius will create one tap point for every note on the top staff of the selection; if you switch 
on Include rests, Sibelius will create one tap point for every rest, too. 

o You can alternatively choose Apply to range of selection, which will add or remove tap points in the 
selected passage, but according to the options set in Frequency of tap points below, rather than using 
the rhythm of the top staff in the selected passage. 

o Apply to entire score ignores any selection in the score, and instead adds or removes tap points 
throughout the whole score, according to the options set in Frequency of tap points below. 

 When adding new tap points, Replace existing tap points allows you to choose whether any existing tap 
points in the affected passage should be replaced (in which case the option should be switched on), or 
whether new tap points should be added without affecting existing tap points (in which case it should be 
switched off). 

 The options in Frequency of tap points determine the rhythmic positions at which tap points should be 
added or removed if not using a rhythm from the score. You can choose whether to add or remove tap 
points every beat, at the start of every bar, or every half-bar. 

Tap points appear on the Live Tempo display in Panorama as blobs: 

 
You can also add tap points by clicking directly on the Live Tempo display: choose Create > Other > Live 
Tempo Tap Point, then click where you want to add a tap point: Sibelius draws a dashed line to help you line 
your tap point up with the rhythm of the music, and when you click it will snap the tap point to the nearest 
rhythmic position (according to the settings on the Mouse page of Preferences). 

If you create tap points based on the rhythm of a passage of music and then change the rhythm of those bars, 
the tap points will not update automatically: you can edit or recreate the tap points using Play > Live Tempo 
Tap Points. 

You can also add and remove tap points simply by double-clicking on the Live Tempo display. 
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Recording Live Tempo using tap points 

Having created some tap points, choose Play > Record Live Tempo to record your performance. In bars 
containing tap points, Sibelius will expect you to tap at particular points, and it will wait for you at each tap 
point rather than allowing the flywheel to continue without you as it ordinarily would. 

You can freely mix passages in which you provide specific tap points, and passages where Sibelius will 
automatically interpret your tapping: after a passage of tap points, when Sibelius encounters a full bar that 
contains no tap points, it will start interpreting your taps in the usual way. 

Scores that begin with a pick-up (upbeat) halfway through a beat now respond correctly when starting Live 
Tempo recording. 

New count-in display 

Live Tempo now also includes a  new count-in display, which appears above the playback line when you 
initiate Live Tempo recording. The display shows the number of beats, and the beat denomination, that Sibelius 
expects you to provide before Live Tempo recording begins. 

4.9 Playback dictionary 
 The behavior of the Sound ID change control in Play > Dictionary has been improved. * 

4.12 Playback Devices 
 Sibelius now fully supports the ARIA sample player used by the new version of Garritan Personal Orchestra 

(GPO4), including automatic loading of sounds without showing a progress bar, just as is possible with the 
built-in Sibelius Player. 

 Sibelius now only displays sound sets in Play > Playback Devices for the built-in Sibelius Player if the 
sound library specified in the sound set is installed. 

 A minor problem with the Essentials Choral Combo sound set (for users of Sibelius Sounds Choral for 
Sibelius 6) has been corrected. † 

 It is now possible to tab through all of the controls in Play > Playback Devices (Windows only). 

 If you happen to give a new playback exactly the same name as an existing playback configuration, Sibelius 
will now automatically rename the new playback configuration to avoid silently failing to create the new 
configuration. * 

 Virtual instruments and effects windows launched from Play > Playback Devices can now correctly be 
brought in front of the Playback Devices dialog (Mac only). 

 Sibelius no longer crashes on exit if it was in the middle of loading sounds into the Sibelius Player. 

 The Test button in Play > Playback Devices now works more reliably when testing sounds loaded into the 
Sibelius Player. 

4.16 ReWire 
 Sibelius is now compatible with Cakewalk Sonar and Cakewalk Music Creator; if you do not set up your 

ReWire track correctly in Sonar or Music Creator, Sibelius will now provide a message as it starts up, 
informing you of the change in settings you need to make in your Cakewalk product (Windows only). 

 Sibelius is now compatible with Adobe Audition (Windows only). 

 A problem whereby it was not possible to quit Cubase when running Sibelius as a ReWire device has now 
been fixed (Mac only). 

 Hitting Esc to stop playback in Sibelius now also correctly stops in the ReWire mixer application (e.g. 
Garageband, Pro Tools). 

 Setting the playback position by clicking or dragging the timeline control in the Playback window now 
works correctly in ReWire mode. 

 Flexi-time input can now be used when Sibelius is running in ReWire mode; note that you cannot alter the 
tempo of recording in this instance. 
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5.5 Comments 
 It is now possible to use Layout > Hide Empty Staves on staves that contain comments. 

5.7 Filters and Find 
 A problem whereby Sibelius would not filter anything if filtering for a range of pitches where one end of the 

range is specified as Any pitch has now been fixed. 

5.11 Ideas 
 Under some circumstances, capturing an idea, closing a score, then re-opening the same score in the same 

session of Sibelius could cause a crash; this has now been fixed (Mac only). * 

 The editable combo box at the top of the Ideas window now works correctly once more (Mac only). 

5.12 Menus and shortcuts 
 It is now possible to define function keys plus modifiers as keyboard shortcuts (Mac only). 

 Two blank entries no longer appear at the top of the list of text styles on the Menus and Shortcuts page of 
Preferences (Mac only). 

5.13 Panorama 
 A problem whereby beams over barlines can cause bars to disappear when scrolling through the score in 

Panorama has been fixed. 

5.17 Properties 
 New Rest Y parameter on the Notes panel of Properties, which makes it possible once more to move rests 

vertically by small amounts. Before Sibelius 6.0, this was achieved by adjusting the Y parameter on the 
General panel of Properties, but that parameter now edits the notional “stem length” of a rest (in the same 
manner that it has always edited the stem length of a note).  

 The Fermata checkbox on the Playback panel of Properties is no longer incorrectly disabled when Play > 
Live Playback is switched off. 

 It is now always possible to open the Playback panel of Properties, even when other panels are open. 

5.19 SibeliusMusic.com 
 File > Publish on SibeliusMusic.com now goes directly to a page on the web site rather than opening a 

local web page. 

5.20 Transposing 
 When transposing a system passage that begins with an Open key/atonal key signature but which later uses 

a regular key signature, the Transpose key signatures option in Notes > Transpose is no longer disabled, 
so it is possible to transpose subsequent regular key changes in the same operation. 

 If you uncheck Transpose key signatures in Notes > Transpose, the next time you enter the Transpose 
dialog, Transpose key signatures is no longer incorrectly disabled. 

5.22 Versions 
 Comparing two versions of a score, or two separate scores, is now up to five times faster than before. 

 Line breaks are now included in the Rich Text Format log exported via the Export Log dialog. † 

 When exporting a version log, Sibelius now always compares the versions in chronological order from oldest 
to newest. † 

 Sibelius no longer crashes if you attempt to navigate between bars in a read-only version using e.g. 
Ctrl+0/1. 
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 Deleting multiple versions in a single operation in the Edit Versions dialog no longer causes Sibelius to crash 
(Mac only). 

 The \$PageNum\ text wildcard is now correctly substituted with the actual page number in version logs, and 
in the preview display in the Edit Versions dialog. 

 The Edit Versions dialog no longer incorrectly shows duplicate entries when multiple scores, each with 
their own versions, are open at the same time. 

 In rare circumstances, it was possible for Sibelius to crash when attempting to view a version via the Edit 
Versions dialog. This no longer occurs. 

 Should Sibelius encounter a version saved in a score that is corrupt or zero bytes in length, it will now 
automatically remove it from the score. 

 The New button in File > Versions > Edit Versions is now disabled if the score has not yet been saved. 

 When comparing two versions or files, added/changed/removed lyrics now correctly show a colored 
background around the whole text object, not just the lyric lines. 

5.23 View menu 
 Using View > Pages > Spreads/Single Pages Vertically, the View > Staff Names and Bar Numbers option 

now correctly displays bar numbers on all pages. 

 Page numbers on the Navigator window are now a darker shade of blue. 

5.25 Worksheet Creator 
 The song Kookaburra has been removed from the Worksheet Creator content due to copyright concerns. 

 Creating certain worksheets (e.g. the posters of individual instruments) no longer causes Sibelius to crash. 

 Various fixes and improvements to the included worksheets and templates. * 

5.26 Adding your own worksheets 
 Clicking Edit Details in File > Edit Worksheets no longer causes Sibelius to crash. 

6.1 Working with plug-ins 
 ManuScript plug-ins now run between two and three times faster than in previous versions. 

 Esc now correctly cancels plug-in dialogs that have Cancel buttons (Mac only). 

 Edit controls in ManuScript plug-in dialogs are no longer multi-line by default, so hitting Return or Enter in 
a plug-in dialog with the focus in an edit control will now activate the default button in the dialog, rather 
than entering a carriage return in the edit control (Mac only). 

 Controls in ManuScript dialogs now have string-based IDs. Sibelius will automatically create an ID for a 
given dialog control, but you can edit them if you wish.  

 It is now possible to enable and disable controls in ManuScript dialogs via their string-based IDs. This makes 
it possible to show multiple dialogs one after the other, updating a specific dialog’s controls while another is 
already visible. The new method is Sibelius.EnableControlById(plugin, dialog, controlID, enable), 
where:  

o plugin is a plug-in object, e.g. Self 

o dialog is a dialog object. Note that this parameter should not be passed in quotations. 

o controlID is the string corresponding to the control to be enabled or disabled 

o enable is a Boolean: when True, the control is enabled; when False, the control is disabled. 

 New global ExitPlugin() method, which exits the plug-in cleanly without dropping into the plug-in 
editor (as a counterpart to StopPlugin(), which does show the plug-in editor).  

 Further improvements to the SparseArray class that was added in Sibelius 6.0:  
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o To iterate over the contents of SparseArray objects, use for each. 

o SparseArray comparison now compares lengths and non-null elements. All null or unassigned 
elements are ignored for equality comparison. 

 Further improvements to the Dictionary class that was added in Sibelius 6.0:  

o To iterate over element values in Dictionary objects, use for each n in Dictionary or for 
each Value n in Dictionary 

o To iterate over element names in Dictionary objects, use for each Name n in Dictionary 

o To iterate over value.name pairs in Dictionary objects, use for each Pair n in Dictionary; this 
returns a new Dictionary object: n.Name is the element name, n.Value is the element value. 

 Fixed a problem whereby validation using IsValid() on a DynamicPart object did not work at all. 

 Object validation via IsValid() is more robust, and a potential crash (if the object being checked was in a 
deleted bar and/or staff and the undo stack had been cleared in the meantime) has been fixed. 

 New Bar.OnNthPageExternal read-only variable, which returns a string containing the external page 
number on which the bar occurs.  

 New Score.InternalPageNumToExternalPageNum(pagenum) method, which returns a string 
containing the external page number of the given internal page number pagenum.  

 A problem that prevented BarObject.SetVoice() from changing the voice of an individual note within a 
note rest has been fixed. 

 It is now possible to clear the contents of an edit control in a plug-ins dialog by setting an empty string as the 
value of the variable assigned to the control. 

 You can now create a comment using its default color by passing -1 as the value for the color parameter in 
the bar.AddComment() method.  

 New BracketsAndBraces and Bracket objects, providing access to the brackets, sub-brackets and braces 
in the score. 

 New DocumentSetup object, providing access to all of the settings in Layout > Document Setup. 

 New EngravingRules object, providing access to selected settings in House Style > Engraving Rules. 

 New Score.SystemObjectPositions read-only variable, returning a SystemObjectPositions object 
corresponding to the settings in House Style > System Object Positions. 

 New Score.Barlines read-only variable, returning a Barlines object, corresponding to the barline 
groupings in the score. 

 New Staff.AddStaffAbove() and Staff.AddStaffBelow() methods, allowing plug-ins to create 
extra staves and ossia staves. 

 New Bar, Staff and Score methods corresponding to Layout > Reset Space Above Staff, Layout > 
Reset Space Below Staff and Layout > Optimize Staff Spacing. 

 New utils.RoundToNDecimalPlaces() method to round a number to the specified number of decimal 
places. 

 New LongInstrumentNameWithFormatting and ShortInstrumentNameWithFormatting variables 
for the Staff object, allowing plug-ins to get/set instrument names including styled string information. 

 New Score.MusicTextFontName, Score.MainMusicFontName and Score.MainTextFontName 
variables, allowing plug-ins to get/set the main fonts used for a score, as specified in House Style > Edit All 
Fonts. 

 Setting the full and short names of an instrument when creating it via 
Score.CreateInstrumentAtBottomReturnStave() now correctly sets the names of all created staves, 
not just the first one. 
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 New InstrumentType.HasKeySignatureOrTuning read-only variable, corresponding to the Key 
signature / Tuning checkbox in the Edit Staff Type dialog.  

 New Bar.GetClefAt(pos) method, which returns a Clef object corresponding to the current clef at the 
specified position within the bar.  

 New Bar.GetKeySignatureAt(pos) method, which returns a KeySignature object corresponding to 
the current key signature at the specified position within the bar.  

 New read-only variables for GuitarFrame objects that return the pitches of the root note and any altered 
bass note for the specified chord symbol as if the score is shown at transposed pitch, but regardless of 
whether Notes > Transposing Score is switched on or off. These new read-only variables are as follows:  

o TransposingChromaticRoot 

o TransposingChromaticBass 

o TransposingDiatonicRoot 

o TransposingDiatonicBass 

o TransposingRootAsString 

o TransposingBassAsString  

 New BarObject.FreezeMagneticLayoutPositions() method, which is the equivalent of selecting an 
object and choosing Layout > Freeze Magnetic Layout Positions. There is also a corresponding 
Score.FreezeMagneticLayoutPositions() method, which performs this operation for the entire 
score. 

 The Sibelius.Print() method now takes an optional third Boolean parameter, which defaults to False, 
but if set to True will show the Print dialog, allowing plug-ins to prompt for settings. 

 New Staff.Small read/write variable, allowing plug-ins to determine or set whether a staff should be 
small. 

 New NoteRest.RestPosition read/write variable, allowing plug-ins to determine or set the vertical 
position of a rest. 

 New Line.RhDx read/write variable, allowing plug-ins to determine the position of the right-hand of lines. 

 Score.SaveAs() now creates any missing folders passed in as part of the path to save the file. 

 New Sibelius.CreateFolder() method that creates a folder, returning the new folder object if 
successful, or null if it fails. 

 New Sibelius.FolderExists() method, which returns True if the specified folder exists, or False if it 
does not. 

 Setting the Hidden variable of a BarRest object now correctly hides the bar rest. 

 Bar.AddSymbol() now returns null if it cannot add a symbol to the score, rather than throwing an error. 

 New Score.SymbolExists() method, to test whether a particular symbol exists in the score before 
attempting to add it. 

 The BarObject Type variable for a guitar bend now returns the value Bend rather than Slur. 

 Score.SystemCount() method now once again returns the correct value, rather than null as it did in 
Sibelius 6.0. * 

 The GuitarFrame.SuffixText variable now returns the exact string that appears in the score for a chord 
symbol that has been converted from a guitar frame created in an earlier version of Sibelius where the chord 
text has been overridden, rather than attempting to provide a default suffix for the underlying chord type. 

 Opening a file using Sibelius.Open with the optional quiet parameter set to true will no longer incorrectly 
show the message warning you to switch on View > Comments if the score contains comments but View > 
Comments is switched off. 
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 List boxes in ManuScript plug-in dialogs now show vertical scroll bars on Windows, as they have done on 
Mac for several versions. 

 Controls in group boxes in ManuScript plug-in dialogs can now always be selected correctly (Mac only). 

 When a combo box or list box in a ManuScript plug-in dialog is set to a value that cannot be found in the 
array that contains the possible values for that control, Sibelius now automatically selects the first item in the 
list, to ensure that the combo box is not drawn empty and the list box is not drawn with no item selected. 

 bar.AddTimeSignature() now works correctly when some parameters are passed in as array values. 

6.2 Accidentals plug-ins 
 Plug-ins > Accidentals > Add Accidentals to All Sharp And Flat Notes has been improved such that it 

now handles sharps and flats on tied chords more reliably. 

6.4 Batch Processing plug-ins 
 Plug-ins > Batch Processing > Export Folder of Scores as Web Pages now correctly lists the available 

Scorch web page templates. 

6.5 Chord Symbols plug-ins 
 Plug-ins > Chord Symbols > Realize Chord Symbols now works correctly with major 7th, half-diminished 

and sus9 chord types. 

6.7 Notes and Rests plug-ins 
 The Move rests with notes option in Plug-ins > Notes and Rests > Make Pitches Constant now works 

correctly once more. 

6.8 Other plug-ins 
 New Plug-ins > Other > Merge Bars plug-in, which acts as a counterpart to the existing Split Bar plug-in.  

 Plug-ins > Other > Make Piano Four Hands Layout has been updated such that it no longer creates fake key 
signatures that are mucked about with by Magnetic Layout. 

6.11 Simplify Notation plug-ins 
 Plug-ins > Simplify Notation > Combine Tied Notes and Rests now runs without an error. † 

6.12 Text plug-ins 
 Plug-ins > Text > Scale Dynamics now works correctly for user-created text styles based on Expression text, 

as well as the Expression text style itself. 

 Plug-ins > Text > Find and Replace Text now works correctly when run with no selection. * 

7.3 Multiple Part Appearance 
 Making a change to the page or staff margins in the Margins dialog accessed from Multiple Part 

Appearance now correctly takes effect immediately; you no longer have to Tab or click in another field first. 

 The Center in the bar checkbox for bar numbers on the House Style tab of Multiple Part Appearance now 
works correctly, changing this setting as appropriate for all the selected parts. 

8.2 Magnetic Layout 
 Tuplets on guitar tab staves that do not show rhythms no longer cause other objects to move out of the way 

of where the tuplet bracket would normally appear. 

 The hidden part of rit./accel. lines no longer incorrectly act as if they are visible, forcing other objects to 
move out of the way. 

 Magnetic Layout will no longer attempt to avoid collisions with hidden beams, accidentals or note-attached 
arpeggios. 
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 If the Timecode text style is made boxed, timecode is no longer forced outside of its own box by Magnetic 
Layout. 

 It is no longer possible to adjust settings for slurs in Layout > Magnetic Layout Options; if you previously 
adjusted the settings for slurs in this dialog, you are recommended to click Restore Defaults to use the most 
up-to-date default settings. 

 Pedal lines now have a more appropriate grouping behavior, and are no longer shown as colliding (i.e. 
colored red) when they abut. 

 Lyrics are no longer unexpectedly shown as colliding when they do not appear to collide, particularly when 
multiple verses of lyrics are present. 

 Trill lines, octave lines, etc. are no longer shown as colliding when they cross a barline. 

 Percussion stickings now have their own settings in Magnetic Layout Options and will be grouped across 
the width of the system. 

 A new option, Use precise Magnetic Layout bounding boxes, on the Beams and Stems page of House 
Style > Engraving Rules, has been added to improve the accuracy of Magnetic Layout for irregularly 
shaped and angled objects, e.g. beams, tuplet brackets, hairpins, etc. This option should be switched on if 
you intend to make use of the improvements to magnetic slurs and collision avoidance for articulations.  

 No bar number bar number changes no longer cause other objects to move out of their way. 

 The hidden target notes for bends on guitar tab staves no longer cause other objects to move out of their 
way. 

 The text part of an instrument change is now allowed to move to avoid collisions. 

 Hairpins are no longer truncated by hidden objects (e.g. hidden dynamics, or other hairpins that are hidden). 

 Layout > Optimize Staff Spacing no longer sometimes fails to move any staves, even when there are 
obvious collisions, if the staves must be moved more than c. 15 spaces to resolve the collisions. 

8.4 Auto Breaks 
 2-bar and 4-bar repeats are no longer treated as one bar for the purposes of auto system breaks. The new 

behavior is that auto system breaks are allowed at the end of a 2-bar or 4-bar repeat, but never in the middle, 
and if Sibelius exceeds the desired width of a system due to one of these repeats (or due to use of Make into 
system or Keep bars together), then it will put in a break as early as possible. Previously Sibelius would 
have waited until the next multiple of the desired system width, but the new behavior is better. 

8.10 Staff spacing 
 Layout > Optimize Staff Spacing no longer sometimes produces unnecessarily large gaps between staves, 

and correctly ignores cross-staff beaming on grand staff instruments. 

 n extra spaces between groups of instruments on the Staves page of House Style > Engraving Rules 
now works correctly regardless of the presence of sub-brackets. 

8.11 Music fonts 
 The tenuto symbol in Opus has been thickened slightly. 

 The capital “Å” and lower-case “å” characters in Inkpen2 Script now have an appropriate width. * 

 Opus Chords and its equivalent fonts have been expanded to include full-size numerals, and sufficient 
characters to allow word-based suffix elements (e.g. “omit”, “add”, “sus”, etc.) to appear both as small 
capitals and lower case, both on the baseline and superscript (with some exceptions in Inkpen2 Chords and 
Reprise Chords, which do not include a full set of lower case letters). 

8.13 Edit Chord Symbols 
 New Use baseline extension number checkbox in the Edit Chord Text Suffix dialog, which is enabled for 

chord types whose extension consists of a number, e.g. C7, C9, C11. If you want these chord types, and 
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extended chord types based on these types, to appear with baseline extension numbers, switch this checkbox 
on for each affected chord type.  

 You can now choose between a more comprehensive set of appearances for word-based extensions and 
alterations (omit, ma, mi, maj, min, m, dim, aug, sus, add, no and alt.), including capitals and lower case 
versions, both on the baseline and superscripted. If you are using Inkpen2 Chords or Reprise Chords, not all 
of the word-based extensions and alterations are available in lower case.  

 A number of new variants of word-based chord suffixes, e.g. maj, min, add, sus, omit, etc. have been added 
consisting of mixed-case words positioned on the baseline. 

9.1 Working with files 
 When Sibelius recovers an auto-saved score, all versions saved in the score are now correctly recovered too. 

9.5 Opening MIDI files 
 MIDI files that contain spurious time signatures should no longer cause Sibelius to hang when it attempts to 

open them. 

 When Show metronome marks is switched off in Open MIDI File, tempo changes in MIDI files are now 
imported as hidden metronome marks, rather than as regular metronome marks preceded by a tilde 
character (~). 

 MIDI files of more than 3000 bars in length are now correctly imported. * 

 MIDI files with more than 256 tracks are now imported correctly. * 

9.6 Opening MusicXML files 
 MusicXML 2.0 files are now validated against the MusicXML 2.0 W3C XML schema definition. Sibelius also 

continues to validate against the MusicXML 2.0 DTDs.  

 Dashed and dotted slurs are now imported from MusicXML files. The placement and orientation 
parameters are not currently imported for slurs: slurs from MusicXML files will always follow Sibelius’s 
default positioning rules.  

 A wide variety of nth-ending lines are now correctly imported. If the MusicXML file specifies an ending line 
that does not exist by default in Sibelius, a new line style will be created to match the appearance and 
behavior of the ending line specified in the MusicXML file.  

 Complex repeat structures including segnos, codas, D.C. and D.S. jumps are now imported from MusicXML 
files. Where Sibelius detects a repeat event in a MusicXML file, it will use the default text or symbol required 
by Sibelius for correct playback, rather than reproducing exactly the appearance of the original MusicXML 
file.  

 Breath marks and caesura symbols are now imported from MusicXML files.  

 Scoop, plop, doit and fall articulations are now imported from MusicXML files.  

 Upbow and downbow articulations are now imported from MusicXML files.  

 Guitar bends, hammer-ons and pull-offs are now imported from MusicXML files.  

 Pedal lines (for piano etc.) are now imported from MusicXML files.  

 Quarter-tone accidentals are now imported from MusicXML files.  

 Colored objects are now imported from MusicXML files.  

 Arpeggio lines are now imported from MusicXML files.  

 Feathered beams are now imported from MusicXML files.  

 Sub-bass F clefs are now imported from MusicXML files. 

 The directive element, used for system markings such as tempo indications, is now imported from 
MusicXML files.  
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 Sibelius now attempts to detect page numbers in credit elements that recur on multiple pages, and if 
possible it creates a single header text object with a page number wildcard, rather than individual header 
text objects on each page. 

 The other-direction element, used for miscellaneous (and typically non-printing) text, is now imported from 
MusicXML files as comments.  

 The part-group element, which describes bracket, sub-bracket, brace and barline groupings, is now 
imported from MusicXML files.  

 Changes of text formatting in the middle of a text object (e.g. a change to bold or italic) are now imported 
from MusicXML files. 

 Metronome marks imported from MusicXML files now include changes of font and/or style, as appropriate. 

 The default text and music fonts used in MusicXML files are now imported, if possible. 

 Sibelius now imports instrument names with music text font characters where appropriate for MusicXML 
files exported from Dolet 5 for Finale.! 

 If instrument names on all staves of a system after the first system of an imported MusicXML file are 
specified not to appear, Sibelius now sets the options on the Instruments page of Engraving Rules 
appropriately such that instrument names do not appear after the first system of the resulting Sibelius score. 

 The heuristic used to determine whether or not an instrument should be treated as an octave-transposing 
instrument has been improved. 

 Stem directions for notes on transposing instruments in MusicXML files have now been improved. 

 Lyric lines on melismatic syllables are now created at the correct length when importing MusicXML files. * 

 Up-beat (pick-up) bars are now imported from MusicXML files with the correct length. * 

 The horizontal positioning of chord symbols imported from MusicXML files where there are chord symbols 
at rhythmic positions where there are no notes has been improved. * 

 It is now possible to open a MusicXML file when not connected to the Internet. * 

 In certain complex multi-voice cases, Sibelius now ensures that appropriate voices are used for notes, on the 
basis that the highest pitches should use voices with stems pointing up, and the lowest pitches should use 
voices with stems pointing down. * 

 Octave lines no longer affect the pitches of both staves of grand-staff instruments (e.g. piano). 

9.7 Opening files from previous versions 
 New Extend tuplet brackets to last note in tuplet checkbox on the More Update Score Options dialog 

(accessed by clicking More Options on the Update Score dialog that appears when you open a score 
created in a previous version of Sibelius), which if switched on resets the duration of tuplet brackets to use 
the new improved positioning in Sibelius 6.1 (see 2.35 Triplets and other tuplets above).  

9.8 Exporting graphics 
 New Anti-aliased checkbox in File > Export > Graphics to determine whether or not exported color or 

grayscale bitmap graphics should be anti-aliased.  

 When exporting EPS files, to export any embedded TIFF files in the score as 8-bit grayscale images, switch 
off Include colored objects in File > Export > Graphics. When this option is switched on, all TIFF files will 
be exported as 24-bit color images, even if they are monochrome or grayscale.  

 It is now possible to export bitmap graphics of whole pages at high resolutions, e.g. 600dpi or greater 
(Windows only). * 

 Page number wildcards in text are now correctly substituted when exporting graphics, both via copy and 
paste and via File > Export > Graphics. * 
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9.9 Exporting MIDI files 
 New Export pick-up bars as full bars padded with rests checkbox in the Export MIDI File dialog, 

switched on by default. Sibelius has always exported pick-up (upbeat) bars at the start of the score as a full 
bar padded with rests at the start of the bar, which works well for playback. However, if you are exporting a 
MIDI file from Sibelius for the purposes of using it as a tempo track in a sequencer or DAW for ReWire sync, 
it is more useful to export an initial pick-up bar as a short bar with a different time signature than the first 
full bar. To do this, switch off this new option.  

9.10 Exporting audio files 
 It is now possible to type filenames including characters like “ü” on a German keyboard into the Export 

Audio dialog (Mac only).  

 Attempting to switch between scores while exporting audio files will no longer cause Sibelius to crash. 

9.12 Exporting to earlier versions 
 Various small problems related to the appearance and positioning of lines that cross system or page breaks 

when exporting scores to Sibelius 5 format or earlier have been fixed. †  


