
Changes in Sibelius 5.1 
The version number of Sibelius 5.1 is Sibelius 5.1.0 build 41 (built Tuesday 9 October 2007). 

Changes marked with an asterisk (*) denote bugs from earlier versions of Sibelius that are fixed in Sibelius 5.1. 

Accidentals 
 The spacing of accidentals on grace notes has now been fixed.  

Arrange 
 Arrange now works correctly with user-edited instruments.  

 The Notes > Arrange dialog now correctly remembers the last Arrange style used (Mac only).  

 Sibelius now correctly shows the last-chosen Arrange style when you re-open Notes > Arrange or Notes > 
Edit Arrange Style.  

 The Standard Arrangement Arrange style now includes all instruments.  

Articulations 
 Moving notes between voices using Alt+2 or z2 etc. no longer causes Sibelius to lose articulations. *  

Barlines 
 It is now possible to design barlines of arbitrary length and positioning on a per-staff type basis; see Edit 

Instruments below.  

Bar numbers 
 Sibelius now once again uses the numeric aspect of the displayed bar number to determine on which 

bars bar numbers should appear, depending on the user’s chosen frequency.  

 New Distance below staff n spaces control for the default position of ranges of bar numbers below the 
staff when centered under a multirest.  

 Changing the frequency of bar numbers no longer changes their vertical position relative to the staff.  *  

 If a rehearsal mark coincides with the start of a multirest, Hide at rehearsal marks is switched on but 
Show range of bar numbers on multirest is switched off (on the Bar Numbers page of House Style > 
Engraving Rules), Sibelius now correctly hides the bar number.  

Beams 
 Beams over system or page breaks now correctly restart after the break, regardless of whether the system 

on which they started is in view.  

Breaks 
 Create > Title Page now provides the option of printing the part name on the title page.  

 You can now use the zoom tool (i.e. marquis selection) on blank pages produced by special page breaks.  

 Positioning of the screen when switching between the full score and a dynamic part with an item on a 
blank page is now improved.  

 Changing the number of blank pages in a special page break, then undoing the change, no longer causes 
the text on the blank pages to be lost.   

 Edits made after a blank page that occurs after the start of the score no longer causes multiple extra blank 
pages to appear in the middle of the score.  

 The layout mark for Layout > Break > Split Multirest no longer draws too far to the left.  
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 Copying and pasting to and from blank pages now gracefully handles attempts to copy inappropriate 
items (i.e. those that cannot appear on blank pages).  

 When special page breaks from the score are set to appear in dynamic parts as regular page breaks, they 
now show the appropriate layout mark (i.e. page break, rather than special page break).  

 When adding text to a blank page, the text now immediately appears once you finish editing; you no 
longer need to force the page to redraw (Mac only).  

Chord diagrams 
 It is once again possible to create barré lines in chord diagrams.  

 Changing the custom chord names for chord diagrams (on the Guitar page of House Style > Engraving 
Rules) no longer causes all the chord suffixes that remained unedited to disappear in Create > Chord 
Diagram.  

Cues 
 Instrument changes in the source passage are now omitted when pasting via Edit > Paste as Cue.  

 Show bar rest with cue (in parts) on the Paste as Cue page of File > Preferences (in the Sibelius menu 
on Mac) now works correctly.  

 Pasting a cue into a bar that already contains notes no longer incorrectly clears the existing notes; when 
you paste a cue using a multiple selection (rather than a passage selection) Sibelius no longer attempts to 
create bar rests, instead simply pasting the notes using the first unused voice.  

 When pasting a cue that contains lyrics and which requires a clef change, the lyrics no longer end up 
being shifted vertically in the destination passage.  

Document Setup 
 The edit controls that previously used right-aligned text (e.g. Width and Height) now use left-aligned 

text, which works around bugs in Mac OS X’s Carbon edit controls relating to selecting with the mouse 
causing characters to scroll out of view, and for the selection highlight to be poorly drawn (Mac only).  

 The buttons for showing the next and previous page in the preview in Layout > Document Setup are 
now correctly enabled and disabled as appropriate.  

Dynamic parts 
 New Hide default page numbers option on the Layout page of Multiple Part Appearance allows you 

to set your parts to have no page numbers. Note that if you create a page number change in a part, the 
page number change will appear even if this option is switched off.  

 New Keep page number change from title pages from score option on the Layout page of Multiple 
Part Appearance, to allow you to choose whether or not to keep any initial page number change that 
belongs to a special page break in the score separately from keeping any page number change that 
belongs to other page breaks after the start of the score.  

 Copy Part Layout now works correctly.  

 Sibelius no longer crashes if you create an ossia, then undo it, then switch to a dynamic part.  

 Importing a house style into dynamic parts now correctly imports the state of the Show bar rests option. 
*  

 Double-clicking a part’s name in the Parts window to view it now correctly sets the focus back to the main 
document window, rather than leaving it in the Parts window (Mac only).  

Edit Arrange Styles 
 You can now correctly save changes made in the Notes > Edit Arrange Styles dialog.  
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Edit Instruments 
 Editing the Full name and Short name fields for instruments containing music font characters (e.g. Eb 

flute) now correctly updates any instances of that instrument in the score.  

 The Edit Staff Type dialog now has extra options allowing you to control the vertical placement of rests, 
useful for staff types that use an unusual number of staff lines.  

 You can now change the design of barlines on a per-staff type basis. You can determine the length of the 
parts of a barline that extend both upwards and downwards from the middle staff line. This allows greater 
flexibility in the length and positioning of barlines.  

 When you change the number of staff lines in a percussion staff type, you can now position noteheads on 
all the staff lines. *  

 If the new Preferences option to display program names rather than sound IDs where available (see 
Mixer and Preferences below) is set to display program names, the menu to choose the default sound 
for an instrument will show the program names provided by the sound sets in the current playback 
configuration instead of sound IDs. When you are editing an unpitched percussion instrument, the menu 
that allows you to choose the specific percussion sound for each notehead will display the names of 
individual drum sounds from each drum map in the sound sets provided by your current playback 
configuration. Note that if you choose sounds from multiple drum maps, Sibelius may not be able to play 
them back, because it can only draw on sounds from a single drum map for an individual instrument.  

 Deleting a multiple selection of unused instruments in House Style > Edit Instruments no longer causes 
a crash.  

Edit Symbols 
 If you change the music font of one of Sibelius’s built-in symbols, Sibelius no longer reverts that symbol 

back to the original music font when you save and re-open the score.  

Edit Text Styles 
 The checkboxes on the Vertical Posn tab of Edit Text Style are no longer incorrectly disabled when you 

select the Snap to top or bottom of page radio button.  

Exporting audio tracks 
 Sibelius no longer adds too much silence at the end of exported audio files.  

 Exporting an audio file to a path containing non-Roman characters now works correctly.  

 Exporting an audio track for a score containing a note tied for more than 32 bars now works correctly.  

 Sibelius no longer crashes if you replace an exported audio file while that file is open in another program.  

 Sibelius will no longer flatly refuse to export audio if you have MIDI devices in your playback 
configuration, but it will warn you that only those staves played back by virtual instruments will be 
included in the export.  

 Sibelius no longer allows you to provide a filename for an audio file that contains illegal characters.  

Exporting graphics 
 All of the options in the File > Export > Graphics dialog are now saved in global preferences, and so are 

remembered between sessions. The exception is the Pages group of options, which are remembered on 
a per-session basis for each score while it is open, and the folder into which the files should be exported is 
also remembered per-session rather than in global preferences.  

 Bold and italic formatting is now correctly exported in EPS files (Mac only).  

 EPS files exported from Sibelius now have the correct dimensions.   
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Exporting MIDI files 
 Exporting MIDI files for a sample library that uses modulation to control dynamics (e.g. Garritan Personal 

Orchestra, Garritan Jazz and Big Band, etc.) no longer takes a lot longer than it should.  

 Sibelius now correctly exports volume and pan settings from the Mixer when exporting MIDI files.  

Flexi-time 
 MIDI controller data is now correctly recorded in Flexi-time.  

 Notes are no longer incorrectly enharmonically spelled during Flexi-time input.  

 When using Flexi-time to record into bars following a final barline, Sibelius now records into the correct 
bars.  

Figured bass and Roman numerals 
 Improvements to the input of function symbols, via changes in its dedicated word menu.  

Hiding objects 
 Filled arrowheads (e.g. for arpeggio lines) now correctly draw fully in gray when hidden.  

Ideas 
 The options concerning ideas that were on the Files page of File > Preferences (in the Sibelius menu on 

Mac) have now been moved to a new Ideas page. 

 New Create instrument changes for unpitched ideas option on the Ideas page of File > Preferences (in 
the Sibelius menu on Mac), which will create an instrument change at the start of the pasted passage in 
the score, if the instrument used by the pasted idea differs from that used by the destination unpitched 
percussion staff.  

 The buttons in the detailed view of the Ideas window are now scaled correctly when the display 
resolution is set to 120dpi (Windows only).  

 When you capture an idea, it is now always shown as selected in the Ideas window (unless it is prevented 
from appearing by the current search term).  

 Sibelius now always shows you a list of tags when you hit Return after typing a tag, making the detailed 
view of the Ideas window now behaves the same as the compact view.  

Input Devices 
 You can now use the extra knobs, sliders and transport buttons on external MIDI keyboards to control 

Sibelius’s Mixer and Playback window controls. Supported keyboards include the M-Audio Axiom, Ozone, 
Keystation, O2 and Oxygen series, together with the M-Audio/Evolution UC33 MIDI control surface. 
Simply choose the appropriate input map from the Input Devices page of File > Preferences.  

 The Find New Devices button has been reinstated on the Input Devices page of File > Preferences.  

 Inputting using a guitar with a MIDI pick-up now works correctly again, and the MIDI channel of highest 
pitched string control on the Input Devices page of File > Preferences now works correctly (Windows 
only).  

 Sibelius no longer inputs notes into the score when the application is in the background and you play on 
your MIDI keyboard.  

 Sibelius no longer forgets whether you have chosen Guitar or Keyboard for a selected input device.  

Installing Sibelius 
 Problems with running Sibelius in a different user account to that in which it was installed have now been 

resolved (Windows only). 
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 When running the Sibelius installer, you will now be prompted to install the Microsoft .NET Framework 2.0 
automatically if it is not installed, rather than be prompted to download it from Microsoft’s web site 
(Windows only).  

Instruments 
 New Don’t change instrument names at start of system after instrument changes option on the 

Instruments page of House Style > Engraving Rules, switched off by default. When switched on, any 
instrument changes in your score will not change the instrument name at the left-hand side of each page, 
i.e. only the instrument name of the first instrument on a staff will ever appear.  

 When using an instrument change on the lower staff of a grand staff instrument, Sibelius now restores the 
previous clef used on that staff at the end of the instrument change.  

 You can now create an instrument change at the start of a dynamic part without affecting the full score.  

 New instruments have been added and are available in all manuscript papers: 

o 1-line Ratchet staff, in the Orchestral Unpitched Percussion family in All instruments  

o New Jazz guitar family in the All instruments ensemble, with new notation and tab jazz guitar 
instruments.  

o New Glass Harmonica instrument, in the Pitched Percussion family in All instruments.  

 Changes to existing instruments, available in all manuscript papers: 

o Temple blocks, in the Orchestral Unpitched Percussion family in All instruments, now use a 
5-line unpitched staff. Write noteheads on the staff lines.  

o Dumbek is now in the Mid East family in the World instruments ensemble, not Africa.  

o 1-line Cymbal staff, in the Orchestral Unpitched Percussion family in All instruments, now 
produces a clash (or piatti) sound rather than a crash sound.  

o The Accordion instrument now has a much larger range.  

o The ranges of Tuba and Tuba in F have been adjusted.  

o The side stick notehead in drum kit staves now produces the correct sound.  

o The marching snares, tenors, cymbals and bass drums now all have Input using pitch set to 
the appropriate MIDI note for each sound, as specified in Tapspace Virtual Drumline.  

o The range of the treble lute instrument is no longer one octave too low.  

o Bata drums are now in the Americas family in World Instruments.  

o The Tabla instrument has been corrected.  

o The upper ranges of the recorder instruments have been adjusted.  

o The Roto-toms instrument is now unpitched, mapping better onto the roto-toms samples 
provided in Virtual Drumline.  

o Solo tenor is now an octave transposing instrument, as it should be.  

 Sibelius no longer crashes if you try to change the order of instruments in your score via the Change 
Instruments button on the first page of File > New.  

Key signatures 
 The Respell remote key signatures in transposing scores option on the Key signatures page of House 

Style > Engraving Rules no longer erroneously affects instruments that only transpose by one or more 
octaves. *  

Look and feel 
 Sibelius now fully supports the Aero theme on Windows Vista, and all controls (including combo boxes 

such as the zoom control on the Sibelius toolbar) now work correctly.  
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 Sibelius now appears with the correct name and icon in the Windows Vista per-application Mixer.  

 Multi-page dialogs (e.g. Preferences, Engraving Rules, etc.) now open more quickly (Mac only).  

 Toggling Notes > Transposing Score, toggling Use multirests (in Layout > Auto Layout), and confirming 
changes in House Style > Engraving Rules are all now much faster than in Sibelius 5.0.  

 Edit controls masked to only accept certain kinds of input (e.g. in Create > Other > Bar Number Change) 
now always accept Backspace.  

 The zoom combo box on the toolbar now returns the focus to the main document window when you hit 
Return or Enter (Mac only).  

 The numerator combo box for Other time signatures in Create > Time Signature, and the Dots per inch 
combo box in File > Export > Graphics both now work as much like they did in Sibelius 4 as currently 
possible using the new Carbon combo box control (Mac only).  

 The edit controls in Layout > Document Setup are now left- rather than right-aligned, thus working 
around bugs in selection and dragging in these Carbon controls (Mac only).  

 Hitting Backspace when editing an item in a table view control (e.g. the name of a hit point in Play > 
Video and Time > Hit Points, or the name of a part in the Parts window) no longer causes the edit to be 
cancelled (Windows only).  

 Navigation using two-finger scrolling on MacBook and MacBook Pro trackpads or using the wheel on the 
Apple Mighty Mouse is now much less sensitive (Mac only).  

 If you accidentally try to close the score with unsaved changes more than once (e.g. by hitting 
Command-W twice), Sibelius will no longer crash (Mac only).  

 Paper textures now scroll correctly off the left-hand side of the screen when you drag the page around.  

 Various problems resulting from Sibelius not detecting when a control has lost focus (e.g. the user has 
clicked or tabbed away) have been fixed (Mac only).  

 Sibelius can now correctly open files with non-Roman characters in their filenames and/or file paths 
(Windows only).  

 The Instrument changes and Copyright fields in File > Score Info are now much larger.  

 When using a Reprise house style, time signatures are now drawn correctly in the Create > Time 
Signature dialog and the Time Signatures page of File > New.  

 Clicking on the score to bring Sibelius back into focus no longer results in the current selection being lost, 
or the score “sticking” to the mouse pointer (Mac only).  

 Message boxes with a Don’t say this again checkbox can now be dismissed by hitting Esc (Windows 
only). *  

 When saving a score for the first time, Sibelius now suggests a filename automatically, based on the Title 
field in File > Score Info, if it is set. *  

 When you use Edit > Go To Bar, Sibelius now tries to bring the selected bar into view at the left-hand side 
of the screen, rather than at the right-hand side. *  

 Sibelius now includes support for Spotlight. Simply type a term into the Spotlight window, and any file 
that contains the term as text (e.g. lyrics, composer text, etc.) will be returned as a match (Mac only).  

Lyrics 
 Hitting space to end editing on the last note in a staff no longer causes Sibelius to end up in a state where 

further keypresses do nothing until you select something else with the mouse (Mac only).  

ManuScript language 
 New Slide read/write variable for Note objects, allowing you to determine whether or not a given note 

has a guitar slide attached to it.  
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 New read-only variables for InstrumentTypes, allowing more complete access to the data associated 
with instrument definitions.  

 SelectSystemPassage() now correctly selects the initial time signature.  

 You can now iterate over notes in a selection directly (e.g. for each Note n in selection). *  

 Type now returns Note for single Note objects, rather than NoteRest. *  

 Deleting a time signature via ManuScript no longer sometimes causes a crash.  

 SaveAsAudio now returns False if the user clicks Cancel during an audio export.  

 Sibelius no longer crashes if you run a plug-in that tries to access the selection with a barline selected.  

 Disabling score redraw while a plug-in is running now also disables updates to the toolbar and the Parts 
window, speeding up the execution of some plug-ins.  

Manuscript paper 
 The default manuscript papers have been recreated, fixing a number of problems.  

MIDI messages 
 Sibelius now correctly sends system exclusive (SYSEX) MIDI messages.  

Mixer 
 You can now choose to have Sibelius display program names instead of sound IDs in the hierarchical 

menus for choosing sounds, in the Mixer and in the Edit Instruments dialogs. The new option When a 
sound set is available, display: Sound IDs / Program names has been added to the Playback page of 
File > Preferences. By default, this is set to Sound IDs. If you change it to Program names, the 
hierarchical menu for choosing sounds will show the sound sets in the current playback configuration as 
the first level of the menu, a rudimentary grouping into Woodwind, Brass, Strings etc. as the second 
level of the menu, and the individual pitched program names from each sound set as the third level of the 
menu. When you choose a program name from this menu, Sibelius automatically sets the playback device 
for that staff to use the one that currently uses the sound set from which you chose the sound. See also 
Edit Instruments above and Preferences below.  

 It is now possible to change the MIDI channel used by a staff in the Mixer when a staff is set to use a 
specific device, and that device is set to use a Manual Sound Set. At all other times, the MIDI channel 
controls are disabled. This allows you to manually allocate individual staves to MIDI channels directly in 
the Mixer, without using sound IDs.  

 You can now remove a sound ID or program name override for a staff in the Mixer, thus resetting the 
initial sound to the default for that instrument, by choosing (Auto) from the top of the menu.  

 Each staff strip now has a test button, allowing you to audition the sound used by each staff in the score.  

 You can now adjust the pan position of each virtual instrument in your configuration. This is useful for 
mono-timbral virtual instruments that don’t respond to MIDI pan messages, e.g. Vienna Symphonic 
Library Vienna Instruments. Changes you make to the pan position of each virtual instrument’s output are 
saved in the playback configuration, and not in the score.  

 Various operations in the Mixer now correctly “dirty” the score.  

 Ossia staves now show the correct sound ID in their staff strips in the Mixer.  

 Tool tips for pan, volume, the MIDI channel read-out and ‘Show plug-in interface’ buttons now appear 
correctly (Windows only).  

 You can now click anywhere on the combo box controls in the Mixer to show the menu, rather than only 
on the little arrow.  

 The button to show a virtual instrument or effect’s interface is now correctly enabled after changing 
playback configuration.  

 Keyboard navigation of the sound ID menu in the Mixer now works as expected (Windows only).  
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 The tool tips for various controls in the Mixer (e.g. for instrument name, name of virtual instrument, etc.) 
are now more informative.  

Multirests 
 The Show ‘1’ above bar rests option in House Style > Engraving Rules now works correctly.  

 You can now change the width of a multirest by dragging the barline at either end, even if that barline is a 
special barline (e.g. a double barline). *  

Music fonts 
 The stackable +/- characters in Opus Chords, Opus Chords Sans, Opus Chords Sans Condensed, Opus 

PlainChords, Reprise Chords and Inkpen2 Chords now have corrected widths.  

 The half note (minim) character in Reprise Metronome now appears correctly. 

 The piano brace character in Reprise Special now scales correctly.  

 Opus Metronome (and its equivalent fonts in the other families) has been updated such that metric 
modulations written using this font always play back correctly. 

Note input 
 If you switch off Play notes as you edit on the Note input page of File > Preferences (in the Sibelius 

menu on Mac), Sibelius will remain completely silent when inputting or editing notes via mouse input, 
alphabetic input or step-time input. It will only play the notes during Flexi-time input or playback. *  

 The note produced by selecting a note (if Play notes as you edit is switched on) no longer sounds too 
long, making the program seem sluggish when transposing notes with the arrow keys etc.  

 The Adjust note spelling in transposing instruments in remote keys option (on the Clefs and Key 
Signatures page of House Style > Engraving Rules) no longer causes notes to be input with peculiar 
accidentals. *  

Opening files from previous versions 
 New Play repeats option on the Update Score dialog, so that scores with this option switched off will 

automatically get it switched on, to ensure correct appearance of bar numbers.  

 When opening a score from an older version, if a staff is set to play back with a sound other than the 
instrument default (i.e. it was overridden in the Mixer in a previous version of Sibelius), Sibelius will now 
attempt to retain the same playback sound, if a sound set of the same name as that used by the score in 
the original version of Sibelius is found in Sibelius 5.  

 Sibelius now correctly sets the playback effect for user-defined lines based on built-in lines when opening 
scores from previous versions.  

Opening MIDI files 
 Various problems relating to the import of unpitched percussion tracks in MIDI files have been fixed.  

 The Use tab for guitars option in the Open MIDI File dialog has been improved.  

 Sibelius now once again considers the range of pitches in a track before deciding what instrument to 
create.  

 MIDI files that contain unsupported MIDI event types or nonsensical time signatures no longer cause 
Sibelius to crash while importing them.  

 Sibelius now correctly imports program changes in MIDI files.  
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Opening MusicXML files 
 Sibelius can now open MusicXML 2.0 files. It does not support all features of MusicXML 2.0. It can open 

both uncompressed (with file extension .xml) and compressed (with file extension .mxl) MusicXML 2.0 
files. At present, only the first MusicXML file within a compressed format file will be imported.  

 New Use page and staff size from MusicXML file option in the Open MusicXML File dialog allows you 
to choose whether or not to use the page size and staff size prescribed by the imported MusicXML 1.1 or 
later file, or whether to use a page size and orientation chosen by the user.  

 New Use instrument names from MusicXML file option in the Open MusicXML File dialog. When 
switched on, Sibelius will use the instrument name determined by the part-name attribute as the 
instrument name in the score. When switched off, Sibelius will use its own default instrument name.  

 New Use layout and formatting from MusicXML file option in the Open MusicXML File dialog. When 
switched on, Sibelius will use the layout and formatting (e.g. system and page breaks) and staff distances 
prescribed by the imported MusicXML 1.1 or later file. When switched off, Sibelius uses its own default 
layout and formatting for the resulting score.  

 New Let Sibelius choose instruments option in the Open MusicXML File dialog, so that you only get 
asked for input once during the import of MusicXML files rather than twice.  

 TIFF graphics in compressed MusicXML 2.0 files are now imported.  

 Detection of instruments in imported MusicXML files is substantially improved.  

 Nested tuplets are now correctly imported from MusicXML files.  

 Single-note and two-note tremolos in MusicXML files are now imported, by importing the tremolo 
element (a child element of the ornaments element).  

 Hidden empty staves in MusicXML files are now imported (by supporting the print-object attribute 
of the staff-details element).  

 Hidden objects, e.g. notes, are now imported correctly from MusicXML files.  

 Unpitched percussion staves in MusicXML files are now correctly imported. Note that MusicXML does not 
fully describe the actual playback sounds that are supposed to be used for each notehead on the 
percussion staff, so it is possible that playback of the resulting staves will not be correct.  

 Different notehead shapes and bracketed noteheads are now correctly imported in MusicXML files.  

 Chord diagrams (guitar frames) are now imported from MusicXML files.  

 Sibelius now rounds the page dimensions of imported MusicXML files to the nearest actual page size, if an 
actual page size is within 0.5mm of the dimension specified by the MusicXML file.  

 Blank pages, including any text and graphics (of an appropriate format) on those blank pages, are now 
imported from MusicXML files.  

 The vertical and horizontal positioning of text such as title, composer, dynamics, technique text etc. is 
now correctly imported from MusicXML files.  

 The vertical and horizontal positioning of lines, including hairpins, are now imported from MusicXML files.  

 Multirests are now correctly imported from MusicXML files.  

 The credit element is now imported, so title, composer, header, footer, copyright etc. text is now 
imported from MusicXML files.  

 font-family and font-size attributes for word, text and lyric elements in MusicXML files are 
now correctly imported. Where font sizes are expressed in CSS terms (e.g. x-small rather than a point 
size), Sibelius uses a fixed mapping to determine the resulting size. Similarly, if the font family is specified 
as music rather than a font name, Sibelius uses Opus Text; if it is specified as serif, Sibelius uses Times 
New Roman; if it specified as sans-serif, Sibelius uses Arial.  

 The justify and halign attributes, which controls left/right/center justification of text in MusicXML 
files, are now imported. The valign attribute for vertical justification is also imported, in a limited way.  
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 If more than half of the key signatures in an imported MusicXML file have cautionary naturals, the 
resulting Sibelius file will show cautionary naturals before each key signature.  

 Sibelius now correctly imports guitar tab staves that use capos, by modifying the tuning of each string as 
necessary and suppressing the display of tunings at the start of the staff.  

 Long, short and regular fermatas are now correctly imported in MusicXML files.  

 The implicit attribute of the measure element is now imported from MusicXML files, allowing 
Sibelius to number bars around mid-bar repeat barlines correctly.  

 Several more note-attached notations (including turns, inverted turns, pluck, fingernail, stress and 
unstress symbols) are now imported from MusicXML files.  

 Accidentals in MusicXML files generated by the Dolet for Sibelius plug-in are no longer always imported 
as hidden. *  

 Various problems relating to correctly determining the lengths of bars in MusicXML files (relating to the 
different ways of describing tuplets, multiple voices, cross-staff beaming, grace notes, etc.), resulting in 
bars that looked correct until you attempted to edit them, at which point it became obvious that the bar 
was the wrong length, have been resolved. * (, , , , , , , ) 

 Hidden bar rests in MusicXML files are now correctly imported as bar rests, rather than whole note 
(semibreve) rests. *   

 Rehearsal marks are now imported correctly from MusicXML files. *  

 Sibelius no longer imports all boxed text in MusicXML files as rehearsal marks; if the text in the object 
does not conform to the expected appearance of a rehearsal mark, Sibelius instead imports it as system 
boxed text. *  

 Multiple articulation marks on the same note are now imported correctly from MusicXML files. *  

 Note stem directions for transposing instruments in imported MusicXML files are now always correct. *  

 Stems are now drawn on the correct side of the notehead in cross-staff beaming in imported MusicXML 
files. *  

 System and page layout in MusicXML files is now more correctly imported. *  

 MusicXML files exported from PDFToMusic Pro no longer import with incorrect system lengths, caused by 
PDFToMusic Pro’s incorrect use of system margins. *  

 Clefs at the end of the bar are now positioned correctly in imported MusicXML files. *  

 Sibelius is now able to open MusicXML files exported from the Dolet for Sibelius plug-in (Intel Mac only).  

 Sibelius now ignores bar rests in the same voice as other notes in the same bar (which can happen in 
some applications when inaccurately describing cross-staff beaming) in MusicXML files. *  

 If a hairpin in a MusicXML file has zero length, Sibelius now automatically extends the hairpin to the end 
of the bar in which the hairpin occurs. *  

 Sibelius no longer offers to change your playback configuration when opening a MusicXML file.  

 Sibelius handles badly-formed MusicXML files more gracefully, avoiding crashes when opening MusicXML 
files with certain problems.  

 Sibelius no longer imports some text in MusicXML files at a much larger point size than specified.  

Page numbers 
 New Hide page numbers until after next page of music option in Create > Other > Page Number 

Change, suitable for ensuring that the page number doesn’t collide with the instrument name at the top 
left of the first page of music in a part with a title page.  

 The settings in Create > Other > Page Number Change are now “sticky” on a per-session basis.  
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Panorama 
 Auto Layout warnings (e.g. V.S.) no longer appear at the end of parts when viewed in Panorama.  

 Sibelius no longer increases the width of the page when adding bars to a Tacet multirest in Panorama.  

 The effect of various operations (e.g. editing Live Playback velocities, running various plug-ins, etc.) is now 
immediately apparent in Panorama, i.e. you no longer have to drag the score to see the effect (Mac only).  

 The shortcut for the Fit page zoom level Ctrl+0 or Command-0 no longer appears to have any effect in 
Panorama.  

 Double-clicking a staff in Panorama now does the same thing as triple-clicking a staff in normal view.  

 Various problems with opening scores and parts at the right zoom level when using Panorama have now 
been fixed.  

 Inputting notes into bars following a split system when using Panorama no longer causes the gap before 
the bar to get larger and larger.  

 When scrolling the score during playback, Sibelius now takes the width of the margin at the left-hand side 
of the screen into consideration, ensuring that the playback line doesn’t end up behind the margin when 
the score scrolls.  

 Using Ctrl+Home or X4 or Ctrl+End or X7 to navigate to the start or end of the score now takes the 
width of the margin into account correctly.  

 The score no longer incorrectly draws behind the margin at the left of the screen when dashed slurs occur 
in the music.  

 The screen now correctly redraws after running some plug-ins (e.g. Renotate Performance) in Panorama 
(Mac only).  

Playback 
 Each virtual instrument and effect window now has extra controls at the top, allowing you to load presets. 

Not all virtual instruments and effects provide presets (for example, Kontakt Player 2 does not support 
presets), so in some cases the list will be empty. You can also save the state of a virtual instrument or 
effect to an .fxp file, and you can load it again, e.g. when using the same virtual instrument or effect in 
another playback configuration. Note that saving a .fxp file in a virtual instrument or effect window has 
does not save the overall playback configuration.  

 Dynamic changes that require a different volume type for samples of multiple notes on unpitched 
percussion staves (e.g. for drum rolls in sound libraries such as Garritan Personal Orchestra) now work 
correctly.  

 Audio Unit effects with MIDI inputs (e.g. AudioEase Altiverb 6) can now be used in Sibelius (Mac only).  

 New Use variant sounds for identical instruments option on the Playback page of File > Preferences, 
allowing Sibelius to automatically take advantage of devices that provide multiple equivalent sounds (e.g. 
different alto saxophones in Garritan Jazz and Big Band), assigning them on a round-robin basis to staves 
that request the same absolute sound ID.  

 New Automatically allocate slot for click track option on the Playback page of File > Preferences (in 
the Sibelius menu on Mac), switched on by default. When this option is switched on, Sibelius 
automatically allocates a channel (or slot in Kontakt Player 2) to the click track. If you switch this option 
off, Sibelius will only allocate a channel (or slot) for the click track at the point at which it is required, e.g. 
when you switch on the Click during playback option in the Playback window, or start Flexi-time 
recording.  

 When deciding which program on which device to use to play back a staff, Sibelius now prefers programs 
that provide greater numbers of switches, since this means that the chosen program is more likely to 
accommodate any changes in relative sound ID with these switches, thus making it less likely that Sibelius 
will change program and/or device unnecessarily.  

 If the same drum map name is found in more than one of the currently-active sound sets, Sibelius will no 
longer potentially choose the wrong drum map for playback.  
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 Sound ID changes including spaces (e.g. +non vibrato) are now played correctly.  

 Relative sound ID changes can now re-use a slot or channel that has previously been used for a different 
relative sound ID on the same staff. This means that if you have to jump to a different lane to do (say) 
staccato, but that same lane also supports pizzicato, then changing to pizzicato will re-use the lane rather 
than attempting to use a new one (which will most likely not be possible in cases where a “fixed” type 
sound set is being used).  

 Sibelius now correctly falls back on +mute if +mute.harmon is requested but unavailable.  

 Sibelius no longer incorrectly penalizes sound IDs found on the same lane that do not provide exact 
matches to the requested sound ID, thus often choosing a less appropriate sound.  

 Sibelius will no longer allocate two staves with different sound IDs to the same slot or channel if it fails to 
find the sounds it is looking for to provide the click track.  

 If a sound can’t be allocated to a slot or channel because there are simply no suitable sounds, Sibelius 
now avoids disturbing the allocation of sounds that it can correctly assign.  

 Sibelius now switches off the sound ID change for a slur (to produce a legato effect) at the end of the last 
note under the slur, rather than at the start of the last note under the slur.  

 Sibelius no longer crashes if you delete a staff, play back the score, undo the deletion of the staff, and 
then play again.  

 Tied notes now play back with their full duration regardless of from where you start playback.  

 Continuous (pitch bend) glissando lines now play back correctly beyond bar 32.  

 Changing the size of the Kontakt Player 2 window now works correctly.  

 Playback of pizz./arco no longer goes wrong when a trill coincides.  

 Slurred notes set to greater than 100% of their notated duration now play back correctly.  

 Lines set to scale the duration of notes now play back correctly.  

 When a staff switches to another sound in another slot or channel, Sibelius now duplicates the volume, 
pan, etc. settings of the original sound, ensuring that the balance is much better.  

 Where fermatas on notes of different rhythmic values overlap, Sibelius now plays them correctly, i.e. it 
waits for the last overlapping fermata before pausing.  

 A single trill line over multiple notes now plays back correctly once more.  

 The tempo read-out in the Playback window is now correct if you edit the effect of the word used by the 
current tempo in the score.  

 Unmeasured tremolos now play back correctly.  

 If you click Cancel in the progress dialog that Kontakt Player 2 displays while loading sounds, Sibelius will 
not continue to load further sounds.  

 When Use same slot for all staves of keyboard instruments is switched on (on the Playback page of 
Preferences), the pan position of the instrument is now correctly determined by the pan slider of the first 
staff in the instrument, and is therefore retained when you stop and restart playback.  

 The playback line no longer leaves traces of itself along the bottom of the window when View > Scroll 
Bars is switched on (Mac only).  

 Multiple grace notes immediately after a note now play back correctly.  

 Some virtual instruments and effects that previously caused a blank window to appear when you showed 
their interfaces now appear correctly (PowerPC Mac only).  

 Dragging the Playback window off the top of the screen no longer causes its height to be reduced 
(Windows only).  

 Successive notes of the same pitch with articulations (e.g. tenuto) or lines (e.g. slurs) that affect their 
durations now play back correctly.  
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 When the prevailing sound is e.g. muted trumpet, Sibelius no longer switches back to an unmuted sound 
if you write staccato notes, and if staccato is supposed to provide a sound ID change but no specific 
staccato sound is available.  

 Hairpins no longer sometimes cause the volume to dip or oscillate dramatically when they are in a 
different voice than the other dynamics.  

 Grace notes preceding trilled notes now play back correctly.  

 When you e.g. select a note in the score and that causes Kontakt Player 2 to start loading sounds, the note 
no longer ends up “stuck” to the mouse cursor once the sounds have finished loading.  

 A hairpin on the final note of the score will now play back correctly, even if it doesn’t have an explicit 
dynamic positioned at its right-hand end.  

 Starting playback midway through a score that has a final barline set to play back (via the Gap after final 
barline option in Play > Performance) no longer causes the gap to be played back after the wrong bar.  

 Sibelius now correctly sends “note off” messages to all active devices when stopping playback, not just 
the first device.  

 Unpitched percussion sounds can now emit complementary controller or keyswitch changes, therefore 
supporting the advanced features of sample libraries such as Garritan Personal Orchestra and Tapspace 
Virtual Drumline.  

 Several improvements to the algorithm used to determine how channels should be shared when Sibelius 
has more staves to play than available channels.  

 Articulations on grace notes no longer upset the playback of changes in playing techniques on 
subsequent notes.  

 Mutual exclusion of playing techniques now works correctly (e.g. “cup mute” should replace “straight 
mute”, rather than make Sibelius believe that it should attempt to find a sound with both “cup mute” and 
“straight mute” properties).  

 For most Kontakt Player 2 sounds, Sibelius can now play continuous pitch bends (e.g. for glissando lines) 
correctly, working around the limitation in Kontakt Player 2 that means it does not respond to standard 
MIDI pitch bend range messages.  

 When starting playback, the playback line no longer appears in the bar before the position where 
playback should start.  

 Sibelius now sends the appropriate program and/or bank change messages when playing back 
unpitched percussion programs from a non-default bank (e.g. on the Yamaha SW1000XG card).  

 Symbols now look forwards or backwards as appropriate to the nearest note in order to apply the 
necessary sound ID change to the right note.  

 Playback of slurs using Garritan Personal Orchestra has been improved (Sibelius now both lengthens the 
note according to the specified duration for Slur above or Slur below on the Staff Lines page of Play > 
Dictionary and emits the appropriate MIDI controller change).  

 Sibelius now sends program and bank messages in the appropriate order, to ensure that program 
changes always take effect when they should.  

 Sibelius now plays back articulations (e.g. staccato) on the second half of a tied pair correctly.  

 When there is a greater number of required sounds than available channels or slots (e.g. when playing 
back a large orchestral score on a single General MIDI device, as in Scorch), Sibelius now allocates sounds 
to channels in an order of precedence (from most important to least important: strings, guitars, brass, 
keyboards, pitched percussion, woodwind, voices, synth, and unpitched percussion), and ensures that if 
pizzicato is required on any string staves, at least two channels are reserved for strings so that switching 
between pizz. and arco doesn’t affect other staves incorrectly.  

 MIDI messages (e.g. controller and program changes) typed into the score as text are now correctly 
chased during playback (i.e. if you start playback following a ~Pn message). Note that these messages are 
not chased when clicking on notes to edit them.  
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Playback Devices 
 The Manual Sound Sets page of Play > Playback Devices now allows you to tell Sibelius to send a 

program change (and associated bank change if required) on each channel at the start of playback. This 
allows you to set up a manual sound set for a device where you do not want to provide sound IDs; 
instead, you can simply set the program number and channel here, and then allocate staves to channels 
using the channel controls in the Mixer (see Mixer above).  

 New When starting Sibelius, load this playback configuration option on the Playback page of File > 
Preferences (in the Sibelius menu on Mac), allowing you to tell Sibelius to always load a particular 
configuration when starting up. This is useful if you have some configurations that take a long time to 
load, but want to ensure that Sibelius starts up as quickly as possible.  

 You can now rename devices in the Active Devices list on the Active Devices page of Play > Playback 
Devices, by clicking on their names.  

 You can now sort the various table view controls in Play > Playback Devices by their column headings, 
by clicking on them.  

 The rows of the table view on the Preferred Sounds page of Play > Playback Devices are now listed in 
the same order as the SoundWorld.  

 Multiple identical playback devices are now sorted properly in ascending numeric order in Play > 
Playback Devices.  

 The number of channels on the Manual Sound Sets page now correctly defaults to the number of 
channels specified in the chosen sound set.  

 You can now choose a Fixed-type sound set in order to set up a manual sound set for a MIDI device, and 
you can also choose a MIDI-type sound set for a Kontakt 2/Kontakt Player 2 device, in order to be able to 
access banks of sounds (if Allow manual sound sets is switched on, on the Playback page of File > 
Preferences).  

 Sound IDs that include accented or other special characters (e.g. keyboard.piano.grand.bösendorfer) 
now appear correctly in the sound ID menus (Mac only).  

 You can no longer choose sound IDs beginning unpitched.* on the Manual Sound Sets page of Play > 
Playback Devices, making it clearer that Sibelius cannot play back unpitched patches on a device 
without a sound set that describes the drum map.  

 Sibelius no longer crashes if you quit while the dialog asking you if you want to save changes to your 
playback configuration is shown.  

 Sibelius now offers to revert to the saved configuration if you try and re-choose the current configuration 
from the Configuration menu when it has unsaved changes.  

 The tree control on the Preferred Sounds page now includes all the sound IDs provided by the sound 
sets in the current playback configuration in addition to the sound IDs in the S3W.  

 You can now tab through the controls in the Play > Playback Devices dialog (Windows only).  

 Attempting to close Play > Playback Devices again after clicking Close but before it has successfully 
closed no longer causes Sibelius to crash.  

 Sibelius now defaults to using the default audio output device (in Audio Engine Options) as specified in 
the Sounds pane of System Preferences (Mac only).  

 Sibelius now shows the correct names for external MIDI devices in Play > Playback Devices (Mac only).  

 New Use manual sound set checkbox on the Manual Sound Sets page of Play > Playback Devices to 
make it clear whether or not Sibelius will treat that device as having a manual sound set.  

Playback Dictionary 
 Words on the Staff Text page of Play > Dictionary that give rise to a Sound ID change can now set the 

duration of that sound ID change (Until the next sound ID change, Until the start of the next note, or 
Until the end of the next note).  
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 Lines on the Staff Lines page of Play > Dictionary that give rise to a Sound ID change can now set the 
duration of that sound ID change (Until end of line, or Until end of last note under line).   

 Sound ID changes set for symbols on the Symbols page of Play > Dictionary are now always 
remembered.  

 As you use the arrow keys to navigate down the lists at the left-hand side of the Staff Text and System 
Text pages, the focus no longer jumps to controls elsewhere in the dialog.  

 Extra words have been added to the Staff Text page of Play > Dictionary for changing between organ 
stops, in e.g. Sibelius Sounds Choral.  

 Poco allarg is now correctly defined to produce a tempo change of 90% rather than 110%.  

 Staff Text items set to do a Program change of 0 are no longer converted to a Sound ID change of 
[reset] when re-opening the score.  

 Adjust durations of notes under line and Transpose by n octaves play effects for lines now work 
correctly if a matching sound ID change can't be found.  

 Sound ID changes for symbols (on the Symbols page of Play > Dictionary) are now saved correctly.  

 All of the radio buttons in Play > Dictionary can now be selected and reselected correctly (Mac only).  

Plug-ins 
 Plug-in dialogs now respond to Return/Enter and Esc as keyboard shortcuts for their default buttons.  

 If you use Plug-ins > Other > Split Bar in a bar containing a change of time signature, the time signature is 
no longer erroneously deleted.  

 Plug-ins > Tuplets > Change Tuplet Ratio now allows you to specify the visual appearance of tuplet 
ratios and tuplet brackets.  

 Plug-ins > Chord Symbols > Realize Chord Symbols and Diagrams now correctly recognises C6‚9 chords 
and has some fixes for the Follow score rhythm chord realization setting.  

 The radio buttons in Plug-ins > Playback > Ornament Playback now work correctly (Mac only).  

 Plug-ins > Composing Tools > Fit Selection to Time now works correctly with a system selection.  

 Plug-ins > Proof-reading > What is Where now recognizes instrument changes.  

 Plug-ins > Composing Tools > Invert now works correctly when using the Chromatic option. *  

Preferences 
 New Ideas page in File > Preferences (in the Sibelius menu on Mac) for options relating to ideas; these 

options have been moved from the Files page. See Ideas above. 

 New Create instrument changes for unpitched ideas option on the Ideas page of File > Preferences (in 
the Sibelius menu on Mac). See Ideas above. 

 New When a sound set is available, display: Sound IDs / Program names option on the Playback 
page of File > Preferences. See Edit Instruments and Mixer above. 

 New Automatically allocate slot for click track option on the Playback page of File > Preferences. See 
Playback above. 

Printing 
 If you click Cancel in File > Page Setup, you can now print using File > Print afterwards (Mac only).  

 Clicking Page Setup in the Multiple Part Appearance dialog now correctly affects all selected parts, not 
just the first one (Mac only).  

 Sibelius now prints the correct page numbers when printing parts that use the \$PageNum\ wildcard.  
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 Sibelius no longer resets the printer's orientation every time you choose File > Print, so you can print 
booklets and spreads without having to reset the orientation before each print (Windows only).  

 Sibelius no longer redundantly warns you that you need to change the Page Setup orientation when 
printing booklets, etc.  

Properties 
 Changing the size of text using the Properties window now works correctly (Mac only).  

 Typing a letter to choose a text style or font from the menus in the Text panel of Properties now works 
correctly (Mac only).  

Registering Sibelius 
 When registering or unregistering Sibelius on Windows, you will now be prompted to enter the username 

and password of an administrator user on your computer during the process. This is to ensure that 
Sibelius is fully compatible with User Account Control in Windows Vista, but also brings security benefits 
in Windows XP. Please note that as a security measure, Windows will not allow you to use an 
administrator account that has no password set. If this affects you, please set a password in the User 
Accounts applet in Control Panel.  

Repeats 
 Codas now play back correctly (Mac only).  

Scanning 
 When sending a PhotoScore file to Sibelius, if the staff is unnamed in PhotoScore, it now appears as e.g. 

Staff 1 in the list of staves detected in the PhotoScore file if you choose Let me choose instruments in 
the Open PhotoScore File dialog. *  

 Sibelius no longer crashes when opening some files generated by PhotoScore Ultimate 5.1.  

Selections and passages 
 If you have a selection when you choose Edit > Select > Select Bars, Sibelius will now select forwards from 

that point rather than selecting backwards to the start of that bar.  

Sibelius Reference 
 Help > Sibelius Reference has been updated with details of all of the new features and improvements in 

Sibelius 5.1. 

Slurs 
 Slurs over page breaks whose left-hand and right-hand ends are positioned on different staves no longer 

change position as the page on which the slur begins moves out of view. *  

Sound sets 
 New sound sets for external MIDI devices in Sibelius 5.1: Roland JV-1080, Roland JV-1080 + Orchestral 

Expansion, Roland SC-8820, Roland SC-88Pro, Terratec AX-50. 

 New sound sets for virtual instruments in Sibelius 5.1: Garritan Gofriller Cello, Garritan Stradivari Violin, 
Vienna Symphonic Library Special Edition. 

 Side drum and snare drum instruments no longer play back normal noteheads as rolls when using 
Sibelius Sounds Essentials.  

 Where there are General MIDI equivalents to sounds provided from a higher-quality source (e.g. Garritan 
Personal Orchestra) in Sibelius Sounds Essentials, the General MIDI sounds are no longer included in the 
sound set. This improves the homogeneity of playback.  
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 In the standard General MIDI set of sounds, Electric Piano 1 is always a Rhodes and Electric Piano 2 is 
always a DX7 or FM-style piano. The sound IDs for these two patches now reflects this in all sound sets.  

 Sibelius can now correctly load the fretted bass patches in Garritan Jazz and Big Band.  

 The muted trumpet patch from Garritan Jazz and Big Band now has a sound ID that correctly describes 
that it uses the harmon mute.  

 Various errors in the Sibelius Gold and Sibelius Gold Eco sound sets corrected.  

 Sound IDs for bongos were incorrect in several sound sets; now fixed.  

 Various fixes to the Garritan Personal Orchestra sound set.  

Splitting and joining scores 
 When appending scores together, Sibelius now always correctly uses the styles information of the original 

score (the one to which you are appending another score), rather than sometimes using the styles 
information of the appended score.  

Symbols 
 New bass accordion coupler symbol added to the Accordion rows.  

Text 
 When inputting text in complex scripts (e.g. Cyrillic, Greek, Japanese, etc.), Sibelius will no longer 

automatically switch the font to the one recommended by Mac OS X’s MLTE text editor. This means that 
you should ensure the font you have chosen for your text contains the appropriate alphabet. If you want 
Sibelius to choose the font automatically for you, switch on Automatically switch font to match chosen 
input source (in the input menu) on the Font Equivalents page of Sibelius > Preferences (Mac only). *  

 Sibelius no longer crashes on start-up if Korean fonts installed with the word processor Hangul 2006 are 
installed (Mac only).  

 The position of text no longer jumps to a different position on the screen when you double-click it to edit 
it.  

 You can now assign shortcuts to items on the Word Menus page of File > Preferences (Windows only).  

 New text style, Create > Text > Blank Page Text > Instrument name at top left (on blank page), used by 
Create > Title Page.  

 Various improvements to word menus: 

o Alt+– or z– now produce a superscript minus character in the chord symbols word menus  

o Ctrl+7/8/9 or X7/8/9 now always produce the appropriate baseline or superscript accidental 
symbols, determined by the specific chord symbols word menu  

o The “stackable” sharp/flat and +/– characters are now accessible from all chord symbols word 
menus  

 The Footnote text style is now positioned correctly.  

Time signatures 
 Changing the time signature size on the Time Signatures page of House Style > Engraving Rules, then 

using undo, no longer causes Sibelius to crash.  

 Sibelius no longer crashes if you create a time signature on a selection where the first bar is out of view.  

View menu 
 View > Staff Names and Bar Numbers now draws bar numbers only over the top visible staff in each 

system, making the display less cluttered.  
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 You can now use either Return (on the main keyboard) or Enter (on the numeric keypad) to confirm a 
change in zoom level typed into the combo box on the toolbar (Mac only).  

Wildcards 
 Typing Return or Enter in multi-line controls (e.g. Other information) in File > Score Info no longer 

produces poorly-aligned text when these fields are used in the score (Mac only).  

Worksheet Creator 
 Creating two worksheets in succession no longer causes Sibelius to crash (Mac only).  

 


