
Updating to Sibelius 3.1.1

For Sibelius 3.0 or Sibelius 3.1 users only
This document details the improvements made to Sibelius 3 since its initial release, and information about updating an existing
Sibelius 3.0 or Sibelius 3.1 installation to Sibelius 3.1.1.

If you have Sibelius 3.1.1 already, please ignore this document and refer to the Latest information and technical help sheet in
your Sibelius box for the latest important information.

Updating to Sibelius 3.1.1 for Windows
* Exit any programs which are running, including Sibelius (choose File > Exit).

% If you are installing the update from the Sibelius 3.1.1 CD-ROM, click Browse this CD in the menu, then go into the Update
Sibelius 3.x to Sibelius 3.1.1 folder and double-click the SibeliusUpdater icon.

% If you downloaded the update from the web site, locate the downloaded file and double-click the SibeliusUpdater icon.
* You will be welcomed to the updater, which will recommend that you quit any running programs – you should already have

done this, so click Next.
* You are given the opportunity to read the updated Sibelius license agreement. This updated license agreement supercedes any

previous license agreements to which you have agreed (e.g. the one printed in the back of your Sibelius User Guide). Click Next
to agree to the license agreement.

* The updater will tell you that it will “update your previous copy of Sibelius in...”, and will show you the path to the existing
installation of Sibelius on your hard disk. Click Next.

* The updater will tell you that it will make backups of all your existing Arrange styles, example scores, manuscript papers, plug-
ins, feature sets, and sound sets, in case you have modified any of them since installing Sibelius 3.0 or 3.1. Click Next. 

* A progress bar appears and the update will install. 
* You’re informed that Sibelius has created a UpdateBackup folder for the items it backed up. Click OK.
* You’re told that your copy of Sibelius has been successfully updated. Click Finish.

% The updater may instruct you to restart your computer, in which case click OK. When your computer has restarted, choose
Start > Programs > Sibelius Software > Sibelius 3 to run Sibelius again.

% If the updater does not prompt you to restart your computer, it will ask whether you want to run your copy of Sibelius 3.1.1
now; click Yes. 

* To check that Sibelius 3.1.1 has been installed correctly, run Sibelius.
* Users updating from Sibelius 3.0: If you had Kontakt Player Silver installed but have not yet updated it, you will be told that the

installed version of Kontakt Player is incompatible with this version of Sibelius – but don’t worry, you can update it in a minute,
so click OK. (Users updating from Sibelius 3.1 do not need to update Kontakt Player Silver.)

* Once Sibelius has loaded, choose Help > About Sibelius; the version number will be version 3.1.1 build 8. Congratulations!
Sibelius has been updated successfully.

* You do not need to re-register Sibelius.
* If, while using Sibelius 3.0 or 3.1, you made modifications to any of the items that were backed up during the update procedure,

you should now restore them by copying the files from the UpdateBackup folder inside your Sibelius 3 program folder back to
the appropriate places.

* If you have a Sibelius 3.1.1 CD-ROM, you should now discard your old Sibelius 3.0 or 3.1 CD-ROM, but ensure you keep the CD
case with your serial number on it.

Updating Kontakt Player Silver for Windows
You should update Kontakt Player Silver after updating to Sibelius 3.1.1 (see above). If you are updating from Sibelius 3.1, you do
not need to update Kontakt Player Silver.

* Exit any programs which are running, including Sibelius (choose File > Exit).
% If you are installing the update from the Sibelius 3.1.1 CD-ROM, click Browse this CD in the menu, then go into the Update

Kontakt Player Silver folder and double-click the UpdateKontakt icon.
% If you downloaded the update from the web site, locate the downloaded file and double-click the UpdateKontakt icon.

* The updater will tell you to quit all running programs, which you should already have done. Click Next.
* You are given the opportunity to read the license agreement. Read it, then click I Accept.



* You will be shown where the updated Kontakt Player Silver will be installed. You shouldn’t need to change this location, but if
you don’t think it has chosen the correct location, click Browse and check. Then click Next.

* You will be shown where the library of sounds will be installed; because you already have Kontakt Player Silver installed, you
can ignore this step. Click Next again.

* You’re asked whether you want to make backups of the files to be replaced during the update. You don’t need to create backups,
but the choice is yours. Click Next when you’ve decided.

* You’re given the opportunity to choose the name and location of the program group in the Start menu. Just click Next.
* A progress bar appears as the update is installed.
* You will be told that Kontakt Player Silver has been successfully installed. Click Finish.
* Now run Sibelius 3 again. You will be told that your MIDI devices have changed. Click OK.
* The Devices dialog will appear, and Kontakt Player will appear as the first device in the Playback Devices list. Click the Test

button, and you will hear a clarinet scale. Make your choices in the dialog, then click OK.
* Finally, choose Help > About Sibelius, and check that the words Kontakt 6.3 are present after the Sibelius version number.

Updating to Sibelius 3.1.1 on Mac
* Quit Sibelius, if it is running (choose Sibelius > Quit Sibelius on Mac OS X, or File > Quit on Mac OS 9).

% If you are installing the update from the Sibelius 3.1.1 CD-ROM, go into the Update Sibelius 3.x to 3.1.1 folder and dou-
ble-click the Sibelius 3.1.1 Updater icon.

% If you downloaded the update from the web site, locate the downloaded file and double-click the Sibelius 3.1.1 Updater
icon.

* You are given the opportunity to read the updated Sibelius license agreement. This updated license agreement supercedes any
previous license agreements to which you have agreed (e.g. the one printed in the back of your Sibelius User Guide). Click
Accept to agree to the license agreement.

* If you have multiple copies of Sibelius installed on your computer, you should click the Select Folder button to ensure you are
updating the correct copy. Otherwise, just click Update. If any applications are running, you will be prompted to quit them;
click Continue to quit all running applications and proceed.

* A progress bar appears as Sibelius is updated. Be patient – this can take a few minutes.
* You are told that installation was successful. Click Quit.
* Restart Sibelius. Choose Help > About Sibelius (in the Sibelius menu on Mac OS X); the version number will be version 3.1.1

build 8. Congratulations! Sibelius has been updated successfully.
* If you have a Sibelius 3.1.1 CD-ROM, you should now discard your old Sibelius 3.0 or 3.1 CD-ROM, but ensure you keep the CD

case with your serial number on it.

Installing Kontakt Player Silver for Mac
You should install Kontakt Player Silver after updating to Sibelius 3.1.1 (see above). If you are updating from Sibelius 3.1, you do
not need to update or reinstall Kontakt Player Silver after updating to Sibelius 3.1.1.

* Quit Sibelius, if it is running (choose Sibelius > Quit Sibelius on Mac OS X, or File > Quit on Mac OS 9).
% If you are installing Kontakt Player Silver from the Sibelius 3.1 CD-ROM, double-click the Install Kontakt Silver icon.
% If you downloaded Kontakt Player Silver from the web site, locate the downloaded file and double-click the Install Kontakt

Silver icon.
* You are given the opportunity to read the license agreement. Read it, and click Accept.
* You are told where Kontakt Player Silver will be installed; change the location if you like, then click Install.
* A progress bar appears as the files are installed.
* If you downloaded Kontakt Player Silver from the web site, you will be prompted to insert your Sibelius 3.0 CD-ROM during

installation (to copy the sound library from the CD to your hard disk).
* You will be told that installation was successful. Click Quit.
* Restart Sibelius 3. After the splash screen appears, the Kontakt Player Audio Setup dialog will appear (refer to Kontakt Player

in your Sibelius 3 User Guide or “Upgrading to Sibelius 3” booklet for details). Make any changes, and click OK.
* You will be told that your MIDI devices have changed. Click OK.
* The Devices dialog will appear, and Kontakt Player will appear as the first device in the Playback Devices list. Click the Test

button, and you will hear a clarinet scale. Make your choices in the dialog, then click OK.



* Finally, choose Help > About Sibelius (in the Sibelius menu on Mac OS X), and check that the words Kontakt 6.3 are present
after the Sibelius version number.

Reinstalling Sibelius 3.1.1
Occasionally you may want to reinstall Sibelius in the location where it is already. If you have a Sibelius 3.1.1 CD-ROM, just install
Sibelius again and it will overwrite your existing Sibelius 3.1.1. There’s no need to install from an earlier CD-ROM and then
update to Sibelius 3.1.1; you can install or reinstall directly from your Sibelius 3.1.1 CD-ROM.

But if you only have a Sibelius 3.0 CD-ROM, you cannot reinstall it over the top of Sibelius 3.1.1. Instead, you should:

On Windows:

* First, uninstall Sibelius 3.1.1. Go to Add/Remove Programs in Control Panel, choose Sibelius 3 (note that Sibelius 3.1 is still
listed as Sibelius 3 in this dialog), and click Remove.

* Do not delete the Sibelius 3 folder that remains, otherwise you will lose your registration (saving function).
* Install Sibelius 3.0 from your original CD-ROM. Ensure that you install it to the same location as you originally did to ensure

that your existing registration is used.
* Then follow the procedure in Updating to Sibelius 3.1.1 for Windows above.

On Mac:

* First, uninstall Sibelius 3.1.1. Trash the Sibelius 3 folder inside your Applications folder (being sure to take backups of any
important files, such as customized manuscript papers, feature sets, plug-ins, etc.), then empty the Trash.

* Install Sibelius 3.0 from your original CD-ROM.
* Follow the procedure in Updating to Sibelius 3.1.1 on Mac above.
* You will need to re-register Sibelius 3.1.1 after reinstalling; choose Help > Register Sibelius and re-register over the Internet.

File compatibility
Sibelius 3.1.1 files are identical in format to Sibelius 3.0 and 3.1 files. As such, Sibelius 3.0 and 3.1 can open files saved from Sibe-
lius 3.1 and vice versa, but no earlier version of Sibelius (e.g. Sibelius 2.11) can open files saved from Sibelius 3.0, Sibelius 3.1 or
Sibelius 3.1.1 (unless you use the special Save as Sibelius 2 feature in Sibelius 3).



New features in Sibelius 3.1.1
These are the new features added since Sibelius 3.0. New features added in Sibelius 3.1.1 are denoted by an asterisk (*).

Bars and bar rests
* When adding bars to the end of the score with Create > Bar > At End (shortcut Ctrl+B or XB) Sibelius no longer moves the

screen to the end of the score.

Files
* Sibelius now conforms to standard Windows and Mac conventions for the behavior of the File > Save dialog: the first time you

save a new score in a session, the save location is set to the default specified in Sibelius’s File > Preferences > General dialog;
when you subsequently save in that session, the save location is set to the last folder chosen by the user.

Flexi-time
* Users of Windows computers with dual processors or single hyper-threading (HT) processors may encounter problems when

using Flexi-time input, with the notation becoming increasingly inaccurate after recording for several bars. A new option
Enable MIDI time stamps (for dual processor machines only) has been added to the Flexi-time page of the Notes > Flexi-
time Options dialog, which you should switch on if you encounter this problem. (This option does not appear on Mac, and is
disabled on Windows if your computer only has a single or non-HT processor.)

House styles
* House Style > Import House Style and House Style > Export House Style now default to the House Styles folder inside the

Sibelius 3 program folder the first time you use them during a session, and remember any other folder you subsequently
choose for the duration of the session.

Instruments
* Several new instruments added which are scored in bass clef but are written in treble clef after part extraction (e.g. tenor, bari-

tone and bass saxophones, trombone, euphonium and baritone horn), plus “Sopranino saxophone in Bb [Soprillo]”, and “Cor-
net in A.”

* The comfortable and professional ranges of the saxophone instruments have been revised; the professional ranges now only
include palm keys and not harmonics.

* New option on the Instruments page of the House Style > Engraving Rules dialog: Gap between instrument names and
initial barline n spaces, which controls the distance between the instrument names and the initial barline of a system when the
staff margins have been reset to fit the width of the longest instrument name. If changed, this option will reset all the staff mar-
gins (including the No names staff margin).

Kontakt Player
* The volume of the Kontakt Player Silver sounds has been boosted.
* It is now possible to change the sound on a staff when playing back via Kontakt Player using the standard ~Pn MIDI message

syntax, provided Kontakt Player has an empty slot into which it can load the required sound.
* New Use Kontakt Player (if installed) option in Play > Playback Options, switched on by default. If you wish to stop Sibelius

from loading Kontakt Player temporarily (e.g. because it adds a little to the processor and memory overhead of running Sibel-
ius) but do not wish to uninstall it, switch off this option, then restart Sibelius. To use Kontakt Player again, switch this option
back on, then restart Sibelius.

* Changing the Reverb control in the Kontakt Player window now maps onto the Distance parameter for the selected staff in
Sibelius’s Mixer window. As a result, changing the Reverb setting in the Play > Performance dialog is now also used when play-
ing back via the Kontakt Player.

* If Use Kontakt reverb is switched off in Play > Playback Options, any changes made to the Reverb controls in the Kontakt
Player during playback are reset to zero when playback is next started.

* Values lower than 44100 have been removed from the Sample Rate menu in the Audio Setup dialog (accessible from
Window > Kontakt Player) to prevent playback problems.

* If Kontakt Player is installed somewhere other than the recommended default, Sibelius is now able to detect it correctly.

Look and feel
* Scroll wheel navigation is now supported on Mac OS X as well as Windows.



* New Scrolling options in the Notes > Note Input Options dialog; the Minimize scrolling when editing checkbox has been
removed and assimilated into a new set of three options:
% Move less often is the default (i.e. during input Sibelius will try to move the score as infrequently as possible, so it will keep

as much as possible of the width of the current page in view)
% Move less far is the old Sibelius 2 behavior (i.e. when you're inputting and you get towards the right-hand side of the screen,

Sibelius will shuffle the score the minimum distance required to bring the new input position into view)
% Keep selection centered is the equivalent of switching off the old Minimize scrolling when editing option (i.e. as you

input notes or use the 0/1 keys or Tab to move between them, the selected object will remain more or less in the middle of
the screen)

* Other improvements to the way Sibelius positions the screen during input, editing and playback, including:
% When extending or retracting a line (such as a hairpin or a slur) with space or Shift-space, the screen now scrolls to keep

the end of the line in view.
% When using R to repeat a selection, the screen now scrolls to keep the repeated selection in view.
% Sibelius now tries to move the score vertically less often during playback. For example, if Fit system width is chosen as the

zoom level during playback, Sibelius will not move the screen vertically if the next system is completely in view. Similarly, if
Sibelius has to scroll to show the bottom system only of a page, it will only scroll as far as necessary to fit the final system on
the screen (i.e. it will no longer scroll the bottom system to the very top of the screen, leaving a large area of desktop visible
below the page).

% When editing or adding a note to a bar that causes the score to reformat and the bar to end up on a different system or page,
Sibelius now correctly keeps this bar in view.

% When the zoom level is Fit 2 Pages or another zoom level where two whole pages fit across the screen’s width, Sibelius now
plays both pages before “turning” the page.

ManuScript language
* Sibelius 3.1.1 includes an updated version of ManuScript Language.pdf (in the Extras folder), including PDF bookmarks, cor-

rections of a few minor errors, and documentation of a few new functions.

Manuscript papers
* The Brass band manuscript paper has been revised.
* The Big band manuscript paper has been revised.
* * The Wind band manuscript paper has been revised.

Note input
* When the user stops inputting notes and hits Esc to make the caret disappear, the Keypad now resets itself to the first layout.
* Enharmonic spelling during step-time input has been improved:

% Sibelius will no longer spell notes as double-flats or double-sharps unless the user has specifically spelled a previous occur-
rence of a note of that pitch in that bar as a double-flat or double-sharp.

% Sibelius now examines every note as it is input (including every note of each chord) and decides how it should be spelled to
minimize the total number of accidentals, unless a note of the same pitch been respelled earlier in the bar, but another spell-
ing gives the same total number of accidentals, in which case the user’s chosen respelling is used instead. The only caveat
with this approach is that if the user changes the spelling of a note and then changes it back again on a subsequent note in the
same bar, Sibelius will continue to use the initial respelling by default.

* Grace notes are now correctly input in the appropriate octave, by choosing the octave nearest the last-input grace note (rather
than the octave of the last “normal” note).

Opening Finale, Allegro and PrintMusic files
* Sibelius tries to detect the language of text in imported Finale files by checking the codepage used for encoding the text in the

file. Text may not be imported correctly or may not display at all if your operating system does not support that language. If the
file contains text of an unknown language, you can choose the Default language of the file you are opening. Use default lan-
guage for all text forces Sibelius to treat all text (except that which uses music fonts, such as Petrucci) in the Finale file as if it
were in the selected Default language; this should normally be switched off.

Opening MIDI files
* The Open MIDI File dialog that appears when you open a MIDI file in Sibelius now allows you to choose the paper size, orien-

tation and house style of the Sibelius file that is subsequently created.



* Improvements to the appearance of percussion notation in imported MIDI files:
% Sibelius now automatically splits the notes in drum staves between voices, with notes positioned on the D5 line or above

going into voice 1, and notes on the C5 space or below going into voice 2.
% New Remove rests between notes on drum staves option on the Notation page of the Open MIDI File dialog, switched

on by default, which significantly improves the appearance of drum staves in imported MIDI files by “joining up” shorter
notes to remove superfluous rests.

Playback
* In order to alleviate the appearance of the Playback Problems dialog on Mac OS X when playing through the DLS Music

Device, Sibelius now automatically sets the default Quality settings (accessible from the Play > Devices dialog) appropriately
for the specifications of the machine it is running on:
% If the processor is a G3 running at 333Mhz or slower, the sample rate is reduced to 22050Hz.
% If the processor is a G4 running at 450Mhz or slower, or if the processor is a G3 running at 600Mhz or slower, reverb is

switched off but the sample rate is left at 44100Hz.
To allow Sibelius to detect the appropriate settings for your computer, you should trash your Sibelius 3 Preferences folder
(inside the ~/Library/Preferences folder) and run the program again.

Plug-ins
* New Color Pitches plug-in:

This plug-in colors notes according to their pitch, a convention occasionally used in educational music. To use this plug-in,
choose the passage in which you want to change the color of notes (or leave nothing selected if you want the operation to
apply to the whole score), and choose Plug-ins > Notes and Rests > Color Pitches. A simple dialog appears, in which you
can choose a color for each of the twelve pitches of the chromatic scale. When you have made your choices, click OK and the
colors are applied to the notes in the selection.
Note that this plug-in is designed for coloring single notes, not chords; any chords in the selection will be colored according
to the pitch of the highest note in the chord.
Plug-in written by Andrew Davis.

* New Boomwhacker Note Colors plug-in:
This plug-in colors notes according to the color scheme of Boomwhacker® tuned percussion tubes (visit the Whacky Music
web site www.whackymusic.com for details). To use the plug-in, choose Plug-ins > Notes and Rests > Boomwhacker
Note Colors. Sibelius will change the color of all the notes in the score and remind you that if you want to print your score in
color, you should switch on Print View menu options in the File > Print dialog.
The plug-in works by changing the colors used by the View > Note Colors > Pitch Spectrum feature and switching it on, so
it does not actually change the score itself. This means that the first time you want to print a score using the Boomwhacker
note colors after running Sibelius, you will need to run the plug-in; you don’t then need to run the plug-in again during that
session of using Sibelius. Because the plug-in switches on the View > Note Colors > Pitch Spectrum option, you’ll find that
every score you work on uses the Boomwhacker note colors – if you don’t want this, choose one of the other options from the
View > Note Colors submenu, or run the plug-in again, which resets the Pitch Spectrum colors back to their defaults.
Plug-in written by Andrew Davis.

* New Harmonics Playback plug-in:
This plug-in enables playback of harmonics, e.g. on string staves, using Sibelius’s Live Playback and MIDI messages features.
To use the plug-in, select the passage in which you want the harmonics to be played back, and choose Plug-ins > Playback >

Harmonics Playback. A simple dialog appears, in which you can choose what kind of harmonics you want the plug-in to
process; generally you can just accept the defaults and click OK. You will be warned to save your score, and then the plug-in
will process the selected passage.
Make sure Play > Live Playback is switched on when you play back your score to hear the harmonics. Beware that if you
transpose the music or otherwise change the pitches of the notes with harmonics after running this plug-in, you should
delete the MIDI message text above the notes and run the plug-in again to ensure correct playback.
Plug-in written by Michael Eastwood.

* New Remove Overlapping Notes plug-in:
This plug-in removes overlapping notes in a staff, and is intended for cleaning up music that was inputted via Flexi-time
(especially from a MIDI guitar) or by importing a MIDI file. It works by cutting off notes that are already sounding when the
next note starts to sound, and it also checks for and removes “dangling” ties (i.e. ties that do not tie to a following note).



To use the plug-in, select the staff or staves on which you want the plug-in to be operated (or leave nothing selected to apply
the plug-in to the whole score), then choose Plug-ins > Notes and Rests > Remove Overlapping Notes. You will be warned
to save your score, and when you click OK, the plug-in will process the selected passage or the whole score. When the plug-in
has finished, you will be told how many overlapping notes were removed.
Plug-in written by Bob Zawalich.

* Improvements to Print Multiple Copies, courtesy of Gunnar Hellquist:
% New Add All button allows you to add all of the scores in the chosen folder to the Print queue list, with the chosen number

of copies.
% New Read Copies button opens each file in the folder and looks for the text ~copies=n attached to any of the first five bars

in the first five staves, where n is the number of copies that should be printed, and adds them to the Print queue list with the
appropriate number of copies set. If a file contains more than one text object of the form ~copies=n it is assumed to be a
score before part extraction and so is not added.

% The plug-in now correctly recognizes Sibelius scores without the .sib file extension (e.g. on Mac OS 9).
* * Improvements to Make Layout Uniform, courtesy of Bob Zawalich:

% Clearer user interface for setting breaks on pages
% Ability to unlock formatting
% Much improved handling of multirests in extracted parts.

* Add Schenkerian Scale Degrees now correctly works in minor keys as well as major ones. Fixed by John Kennedy.
* Invert now produces correct diatonic inversions. Fixed by Gunnar Hellquist.
* Realize Chord Symbols is now called Realize Chord Symbols and Diagrams.
* Find and Replace Text no longer crashes on Windows 98/Me.
* Realize Figured Bass now runs without any problems on Mac OS 9.
* * Save Folder of Scores as Web Pages now works correctly with Netscape 7.1 (as well as other major browsers) on Mac OS X.
* Clicking the Stop Plug-in button while a plug-in is running on Mac OS X no longer causes Sibelius to crash.

Preferences
* If any message boxes are hidden by the user by switching on Don’t say this again, these messages can all be reset to be shown

again as appropriate by clicking the Show All Messages button in the File > Preferences > General dialog (in the Sibelius
menu on Mac OS X).

Registering Sibelius
* New Help > Unregister Sibelius dialog. This option has been added to allow users to move either of their two registered copies

from one machine to another without having to contact Sibelius technical support.
Simply choose Help > Unregister Sibelius on the computer you want to move from; that copy will be unregistered and will no
longer be able to save. You can then install Sibelius on another computer and use Help > Register Sibelius to register Sibelius
over the Internet in the normal way.
This method requires that both computers (the one on which you are unregistering Sibelius, and the one on which you are sub-
sequently registering Sibelius) be connected to the Internet. If either or both of the computers are unable to connect to the
Internet, you should contact Sibelius technical help for assistance in moving a registered copy of Sibelius from one computer to
another.

Repeats
* 1st and 2nd ending lines in codas are now correctly played back. Note that you must insert a start repeat barline at the begin-

ning of the coda (which you can hide if you wish) to make it explicit that an end repeat barline in the Coda should repeat to the
beginning of the coda.

* In newly-created scores, it is now possible to type Coda and Fine instructions in your score in a variety of ways (e.g. “Coda”,
“CODA” and “coda” are all equivalent). “D.S.” and “D.C.” must always be typed in upper case to be correctly detected.

* “jump to” text attached to the beginning of the first bar now plays back correctly.

Scanning
* A new version of PhotoScore Lite (v3.1) is available (on the Sibelius 3.1.1 CD-ROM, or for download from www.sibelius.com/

helpcenter/upgrades.html). If you have PhotoScore Professional 3.0, a free update to PhotoScore Professional 3.1.1 is avail-
able for download from www.neuratron.com.



* The Open PhotoScore File dialog that appears when you open an .opt file in Sibelius now allows you to choose the paper size,
orientation and house style of the Sibelius file that is subsequently created.

Triplets and other tuplets
* The default placement for tuplets with brackets is now set to the stem end (rather than the previous default of always going

above) in newly-created scores. To change placement of tuplets in existing scores, set With bracket to Stem end on the Tuplets
page of House Style > Engraving Rules.



Other improvements
Detailed below are some of the issues and problems reported by users in Sibelius 3.0 and previous versions that have been fixed in
Sibelius 3.1.1. Improvements since Sibelius 3.1 are marked with an asterisk (*). There are dozens of other fixes and improvements
not listed here:

* For more details of fixes between Sibelius 3.0 and Sibelius 3.1, see www.sibelius.com/helpcenter/en/a382

* For more details of fixes between Sibelius 3.1 and Sibelius 3.1.1, see www.sibelius.com/helpcenter/en/a385.

Arrange
* A number of Arrange styles had descriptions longer than 255 characters, causing them to appear truncated on the Mac. These

have now been shortened so that they appear correctly.

Barlines
* Adding a special barline to a selected barline that is not in view no longer causes Sibelius to crash.

Beams
* Sibelius now always remembers the beam groups chosen for each different time signature within the same session (it is no

longer necessary to click the Beam and Rest Groups button in the Time Signature dialog to confirm the previously-chosen
beam groups).

Default positions
* Problems with the Lyric-style input checkboxes in the House Style > Default Positions dialog have been resolved (Mac only).

Edit Sound Sets
* Sibelius no longer erroneously adds 1 to program numbers entered on the Sounds tab of the Play > Edit Sound Sets dialog,

leading to incorrect sounds when using the sound set.

Edit Staff Types
* Replaced the Choose button on the Percussion page of the Edit Staff Type dialog with a drop-down menu listing all the note-

heads.

Files
* Page margins of manuscript papers are no longer reset when creating new scores from the File > New dialog.

Flexi-time
* Flexi-time quantization has been significantly improved.
* When recording with Flexi-time in scores that begin with a pick-up (upbeat) bar, Sibelius now provides a click count-in of the

number of bars specified in Notes > Flexi-time Options (by default, one full bar) plus a further whole bar in which recording
begins on the appropriate beat to match the pick-up bar.

* Inputting into percussion staves using the pitches defined in the staff type (an option in the Notes > Note Input Options dia-
log) no longer suffers from significant latency.

Guitar notation
* Adding a tab staff type change to an existing notation staff now results in the tab being fingered correctly on appropriate strings,

rather than notated below the bottom string.
* Transposing part of a bar of guitar tab now only transposes the selected passage, and no longer erroneously transposes the non-

selected notes in the bar too.

Installing Sibelius
* On multi-user Windows 2000/XP systems, it is now possible for non-administrator users to use Kontakt Player after it was

installed by the Administrator user.

Instruments
* Various cosmetic and accessibility improvements to the Layout > Instruments and Staves dialog.
* Adding further instruments to a score with existing instruments now places the instrument at its correct position relative to the

existing instruments’ position in the All instruments ensemble.
* * The range of double bass instruments has been corrected.

http://www.sibelius.com/helpcenter/en/a382


* * Various problems with the transposition of low clarinets and saxophones have been corrected.

House styles
* * Sibelius no longer crashes when attempting to load a house style file that does not have a .lib file extension (Mac OS X only).

Key signatures
* Using the arrow keys to navigate the Create > Key Signature dialog now always results in the correct key signature being cre-

ated.

Layout and formatting
* When copying and pasting passages in a score, the staff margins (in Layout > Document Setup) are no longer recalculated

unnecessarily. The staff margins will change only if the music being pasted comes from another score in which the Instrument
names text style uses a different font or point size.

Live Playback
* When View > Live Playback Velocities is switched on, you can change the vertical position of the Live Playback velocity col-

umns relative to the staff by holding down Ctrl or X and dragging one of the columns with the mouse. The columns can be
dragged up to 20 spaces above or below the staff.

* View > Live Playback Velocities no longer displays velocity bars over hidden notes when View > Hidden Objects is switched
off.

Look and feel
* The Sibelius toolbar no longer stops responding or disappears (e.g. when performing processor intensive operations such as

opening MIDI files, printing, or switching between applications while Sibelius is “busy”) (Windows only).

Lyrics
* Lyric hyphens no longer appear and disappear as you zoom the score in and out.

Menus and shortcuts
* * Keyboard shortcut problems when using non-English keyboard layouts on Mac OS X have been resolved.
* Closing scores with the XW shortcut no longer causes Sibelius to crash (Mac OS X only).

Mixer
* When adding further instruments after initially creating a score, Sibelius now correctly assigns sequential MIDI channels to

new staves in the Mixer, starting with the next unused channel. When all 16 channels are in use, Sibelius loops around and
starts assigning instruments from channel 1 again.

Note input
* Under certain circumstances, Sibelius would not always choose the note in the nearest octave to the preceding note in alpha-

betic input; this no longer occurs.
* Hitting Tab with nothing selected now correctly selects the first bar rest in the first bar of the page.
* Switching on the Live velocity option on the Playback panel of Properties while the note input caret is visible no longer causes

Sibelius to crash.

Note spacing
* When increasing the spacing of a passage including grace notes, the position of grace notes relative to the main note remains

unchanged.
* The default space after a grace note and before a “normal” note is now set to 0.5 spaces in newly-created scores. To change the

default in existing scores, change the Extra space after last grace note parameter in House Style > Note Spacing Rule.
* Changes to values in the House Style > Note Spacing Rule dialog are now undoable.

Opening MIDI files
* If Sibelius is the default application for opening MIDI files, the program now launches correctly and displays the Open MIDI

File dialog when the user double-clicks on a MIDI file to launch Sibelius (Windows only).
* Importing certain MIDI files could cause Sibelius 3 to appear to hang or eventually crash; this problem has now been resolved.
* Under some circumstances, Sibelius could crash when importing very large MIDI files; this problem is now fixed.



Optimization
* Problems on Windows 98/Me with Sibelius taking a very long time to start up, or even to freeze and never fully load, have been

solved.
* In Sibelius 3.0, screen redraw and editing operations became increasingly slow towards the end of long scores. This problem has

now been fixed; performance in long scores is now comparable with Sibelius 2.1.1.
* Editing operations on long passages are no longer substantially slower in Sibelius 3 than they were in Sibelius 2 (e.g. selecting a

number of bars and hitting 3/2 to change their pitches). The reduction in speed was due to the new Optical spacing algorithm
in Sibelius 3, which recalculates the spacing of notes when their pitch changes, in order to ensure that things like leger lines and
accidentals don’t collide (in Sibelius 2, spacing was never recalculated when notes were repitched). The Optical spacing algo-
rithm has been optimized, and this kind of operation is now between 5 and 10 times faster in Sibelius 3.1.1 than Sibelius 3.0.

* Problems with intermittent crashes caused by using the Enable copying with the mouse option in the File > Preferences >

General dialog have been fixed.
* When minimized to the dock or otherwise put into the background, Sibelius now unloads the DLS Music Device, reducing the

overall CPU usage when the program is not in the foreground (Mac OS X only).
* Plug-in Trace Window no longer overloads the CPU (Windows only).
* Sibelius 3 now correctly runs if no soundcard is installed on the computer.

Playback
* Two-note tremolos now play back with the correct number of notes (previously they often played back with one note too many,

causing one note to hang over into the next bar).
* Playback of trilled tied notes no longer “jolts” at barlines.
* Changes to percussion staff types are now immediately reflected in playback (e.g. changing the number of staff lines, or chang-

ing the sound used by a particular notehead at a particular position on the staff).
* * The note played by Sibelius when selecting a note in the score or inputting a new note (i.e. the Play notes as you edit option

in Play > Playback Options) is now always the correct length (Windows only).

Printing
* The Substitute Braces option in the File > Print dialog now works as before (Windows only).

Properties
* When restarting Sibelius, it now remembers the open/closed state of the panels of the Properties window.

Registering Sibelius
* Extended characters (such as accented or non-European characters) now display correctly in the registration details on the

Sibelius splash screen and in Help > About Sibelius (in the Sibelius menu on Mac OS X).

Saving audio tracks
* File > Save As Audio Track now works on Mac, provided Kontakt Player Silver is installed.
* If Sibelius is going to overwrite an existing .wav/.aiff file, it now warns the user and gives them the option to cancel.
* Sibelius no longer crashes on some computers at the conclusion of saving an audio track.

Saving graphics files
* TIFF files saved using the options for Macromedia Freehand and Macromedia Fireworks in the File > Save as Graphics dialog

now use PackBits compression, which allows them to be opened in these applications.
* Saving a PICT file no longer causes Sibelius to crash (Mac OS X only).

Saving MIDI files
* Exporting a MIDI file with Immediate program changes (in Play > Playback Options) switched on no longer causes tracks

in which there are program changes to appear either much too early or much too late in the exported MIDI file.

Scanning
* If PhotoScore is already running and the user chooses File > Scan or clicks the scanner button on Sibelius’s toolbar, Sibelius now

brings the running instance of PhotoScore to the foreground rather than running a new copy.



Selections and passages
* The message “There is something in view that is not in view...” no longer appears erroneously when View > Hidden Objects is

switched off.
* There is no longer a delay when deleting a selected object on Mac OS X.
* * Copying system passages containing changes of time signature no longer causes the bar before a time signature change to be

pasted the wrong length.

Text
* Changing the text style of an object that contains characters in different fonts no longer changes all of the characters in the text

object to the font of the first character.
* * Creating time signatures using text (e.g. Create > Text > Other staff text > Time signatures (one staff only)) now works cor-

rectly on Mac OS X.

Timecode
* If House Style > Timecode is set to display Above every bar, and an ambiguous repeat structure in the score means that some

bars will never be played, Sibelius will no longer crash.

View menu
* Zoom levels of Fit page and Fit 2 pages no longer display the score much smaller than the available window size.
* The Dialogs, brushed steel and Brushed steel textures have been removed.

Voices
* Changing voices of a passage selection using the buttons at the bottom of the Keypad now correctly lets you change the passage

back to voice 1.

Window menu
* When running Sibelius on multiple monitor systems, the floating windows (Properties, Mixer, Keypad, Navigator, Kontakt

Player) now retain their position between sessions if placed on the secondary display. 
* It is no longer possible to drag the floating windows (Navigator, Keypad, Properties, Mixer) completely off the screen, such that

it’s impossible to get them back.
* * Double-clicking the title bars of the floating windows (Navigator, Keypad, Properties, Mixer) no longer causes them to “stick”

to the mouse pointer (Mac OS X only).


	Updating to Sibelius 3.1.1
	For Sibelius 3.0 or Sibelius 3.1 users only
	Updating to Sibelius 3.1.1 for Windows
	Updating Kontakt Player Silver for Windows
	Updating to Sibelius 3.1.1 on Mac
	Installing Kontakt Player Silver for Mac
	Reinstalling Sibelius 3.1.1
	File compatibility

	New features in Sibelius 3.1.1
	Bars and bar rests
	Files
	Flexi-time
	House styles
	Instruments
	Kontakt Player
	Look and feel
	ManuScript language
	Manuscript papers
	Note input
	Opening Finale, Allegro and PrintMusic files
	Opening MIDI files
	Playback
	Plug-ins
	Preferences
	Registering Sibelius
	Repeats
	Scanning
	Triplets and other tuplets

	Other improvements
	Arrange
	Barlines
	Beams
	Default positions
	Edit Sound Sets
	Edit Staff Types
	Files
	Flexi-time
	Guitar notation
	Installing Sibelius
	Instruments
	House styles
	Key signatures
	Layout and formatting
	Live Playback
	Look and feel
	Lyrics
	Menus and shortcuts
	Mixer
	Note input
	Note spacing
	Opening MIDI files
	Optimization
	Playback
	Printing
	Properties
	Registering Sibelius
	Saving audio tracks
	Saving graphics files
	Saving MIDI files
	Scanning
	Selections and passages
	Text
	Timecode
	View menu
	Voices
	Window menu


