'Trying to route Sibelius to Logic using IAC Bus…'

Messages in this thread

Trying to route Sibelius to Logic using IAC Bus… - musicman288, 06 Jan 01:19AM
     Re: Trying to route Sibelius to Logic using IAC... - musicman288, 06 Jan 01:20AM
         Re: Trying to route Sibelius to Logic using IAC... - Robin Walker, 06 Jan 07:26AM
             Re: Trying to route Sibelius to Logic using IAC... - musicman288, 07 Jan 05:31PM
                 Re: Trying to route Sibelius to Logic using IAC... - musicman288, 07 Jan 05:48PM
                     Re: Trying to route Sibelius to Logic using IAC... - musicman288, 07 Jan 06:27PM
                         Re: Trying to route Sibelius to Logic using IAC... - Robin Walker, 07 Jan 06:48PM

Trying to route Sibelius to Logic using IAC Bus…
Posted by musicman288 - 06 Jan 01:19AM
Hello,
I followed the instructions in the link below and I have it working for most instruments in my score. However, I can't get my Drum part to trigger the drums in Logic. Every time I click on a note in the drum part in Sibelius (8.7.2), it changes the Mixer from Unallocated to blank and nothing plays. I'm attaching the .sib file and a screenshot. Any help would be appreciated!

https://www.scoringnotes.com/tutorials/route-sibelius-or-finale-midi-to-logic-via-iac-bus/
Attachment Quartet w: Piano -> Logic.sib (83K)

Back to top | All threads
 
Re: Trying to route Sibelius to Logic using IAC Bus…
Posted by musicman288 - 06 Jan 01:20AM
Here is the screenshot of the mixer.
Attachment Mixer_Window.jpg (107K)

Back to top | All threads
 
Re: Trying to route Sibelius to Logic using IAC Bus…
Posted by Robin Walker - 06 Jan 07:26AM
Make sure that the drum staff is on MIDI channel 10.

--
Sibelius 8.7.2/7.5.1/7.1.3/6.2/5.2.5, PhotoScore Ult 8.8.2, Dolet 6.6 for Sibelius, Windows 10 64-bit 16GB. Desktop, and Microsoft Surface Book.

Back to top | All threads
 
Re: Trying to route Sibelius to Logic using IAC Bus…
Posted by musicman288 - 07 Jan 05:31PM
When you say drum staff, do you mean changing the Channel in the mixer? I tried that and it didn't work. Of course, I also changed the midi channel on the drum channel strip in Logic to Channel 10.

Back to top | All threads
 
Re: Trying to route Sibelius to Logic using IAC Bus…
Posted by musicman288 - 07 Jan 05:48PM
The drum staff always seems to be tied into the Click track. When I change the midi channel on the Drum channel (Sibelius) it makes the click track turn to a "-" (dash). Also, when I change the instrument from drums to anything else, the midi to Logic connection works. For some reason, the drum instrument will not trigger midi in Logic.

Back to top | All threads
 
Re: Trying to route Sibelius to Logic using IAC Bus…
Posted by musicman288 - 07 Jan 06:27PM
UPDATE: I found by editing the Instrument and changing the staff from “Unpitched” to “Pitched”, it now triggers the software instrument in Logic. However, the mapping isn't correct. I need the bottom space to be the bass drum and the middle space to be the snare, etc. How do I fix this?

Back to top | All threads
 
Re: Trying to route Sibelius to Logic using IAC Bus…
Posted by Robin Walker - 07 Jan 06:48PM
You would have to fix that in Logic somehow. You can't expect two different notation applications to share the same ideas about drum mapping, especially when you've removed information by making the staff "Pitched".

--
Sibelius 8.7.2/7.5.1/7.1.3/6.2/5.2.5, PhotoScore Ult 8.8.2, Dolet 6.6 for Sibelius, Windows 10 64-bit 16GB. Desktop, and Microsoft Surface Book.

Back to top | All threads
 

Quick reply

To add a reply to the end of this thread, type it below, then click Reply.

(.sib, .png and .jpg only)

Messages in this thread

Trying to route Sibelius to Logic using IAC Bus… - musicman288, 06 Jan 01:19AM
     Re: Trying to route Sibelius to Logic using IAC... - musicman288, 06 Jan 01:20AM
         Re: Trying to route Sibelius to Logic using IAC... - Robin Walker, 06 Jan 07:26AM
             Re: Trying to route Sibelius to Logic using IAC... - musicman288, 07 Jan 05:31PM
                 Re: Trying to route Sibelius to Logic using IAC... - musicman288, 07 Jan 05:48PM
                     Re: Trying to route Sibelius to Logic using IAC... - musicman288, 07 Jan 06:27PM
                         Re: Trying to route Sibelius to Logic using IAC... - Robin Walker, 07 Jan 06:48PM