'Latency'

Messages in this thread

Latency - Tijana, 02 Dec 11:33PM
     Re: Latency - Peter Roos, 03 Dec 02:17AM
         Re: Latency - Tijana, 03 Dec 09:36AM
             Re: Latency - Robin Walker, 03 Dec 10:30AM
                 Re: Latency - Tijana, 03 Dec 10:52AM
                 Re: Latency - Tijana, 03 Dec 10:53AM
                     Re: Latency - Robin Walker, 03 Dec 11:37AM
                         Re: Latency - Laurence Payne, 03 Dec 02:36PM
                             Re: Latency - Tijana, 03 Dec 07:48PM
                                 Re: Latency - Tijana, 04 Dec 11:16AM
                                     Re: Latency - Tijana, 06 Dec 09:22PM
                                         Re: Latency - Robin Walker, 06 Dec 10:24PM
                                             Re: Latency - Tijana, 07 Dec 12:36AM
                                                 Re: Latency - Tijana, 07 Dec 12:46AM
                                                     Re: Latency - Robin Walker, 07 Dec 08:03AM
                                                         Re: Latency - James, 08 Dec 06:17PM
                                                             Re: Latency - Laurence Payne, 08 Dec 07:32PM

Latency
Posted by Tijana - 02 Dec 11:33PM
Hi!

I bought Alesis V61 midi controller, and the delay between playing and the sound is unbearable. I tried so many things, but nothing works. I tried calibration, but it only reports that there is e.g. 199ms latency, but it does not solve the problem. What is the next thing I should do?

Thanx!

Back to top | All threads
 
Re: Latency
Posted by Peter Roos - 03 Dec 02:17AM
What sound card are you using, and can you give us specifics about your computer setup? (windows or mac, etc.)

Latency is almost always caused by a cheap sound card (like the one built into computers), bad driver, etc.

It's not your midi controller.

--
Peter Roos
www.summeroflovemusic.com
IMDb: www.imdb.com/name/nm2039241

Back to top | All threads
 
Re: Latency
Posted by Tijana - 03 Dec 09:36AM
Dear Peter,

Thank you for your quick response. I have Dell Vostro 15 laptop with built-in sound card Realtek Audio.

I have Widows 10.

Thanx!

Back to top | All threads
 
Re: Latency
Posted by Robin Walker - 03 Dec 10:30AM
And what Sibelius "Playback Configuration" are you using? If the playback is being performed by the "Microsoft GS Wavetable Synth", then you will suffer extreme latency for which there is no cure. For low latency output, you MUST use a VST-based audio player, such as Sibelius Player with the "Sibelius 7 Sounds" sample library.

The built-in Realtek audio chips are cheap consumer-grade stuff, which are not capable of performing very well with Sibelius.

Please attach screen-shots of the following Sibelius dialogue windows:
1. Playback Devices (on the active devices tab);
2. Audio Engine Options;
and also list for us all the available choices in the "Interface" menu of Audio Engine Options.

--
Sibelius 8.7/7.5.1/7.1.3/6.2/5.2.5, PhotoScore Ult 8.8.2, Dolet 6.6 for Sibelius, Windows 10 64-bit 16GB. Desktop, and Microsoft Surface Book.

Back to top | All threads
 
Re: Latency
Posted by Tijana - 03 Dec 10:52AM
Dear Robin,

Thank you for your efforts. Yes, you are right, it is MS GS Wavetable Synth.

Audio engine options is attached, I will attach the Playback Devices in a second.

T.
Attachment Audio engine options.jpg (211K)

Back to top | All threads
 
Re: Latency
Posted by Tijana - 03 Dec 10:53AM
Attachment Playback devices.jpg (153K)

Back to top | All threads
 
Re: Latency
Posted by Robin Walker - 03 Dec 11:37AM
1. You are using "Microsoft GS Wavetable Synth" as player device, so that will cause terrible latency, which is incurable.

2. You appear not to have installed the "Sibelius 7 Sounds" sample library, which you need to do if you wish to have lower latency output from Sibelius. You can download the "Sibelius Sounds" sample library installer from your Avid account at:
http://my.avid.com/products
Make sure that you download the large installer, not the small "updater".

3. After switching to Sibelius Player, you can reduce output latency still further by reducing the size of the "Buffer size" in Audio Engine Options. But, if you make it too small, playback will break up and distort because the Realtek chip cannot keep up. This adjustment will not help with "Microsoft GS Wavetable Synth".

3. Please ensure that the Windows Device Driver for the Realtek chip is up-to-date. To do this, open Windows "Device Manager", expand the section "Sound, video and game controllers", double click the item there for Realtek, select tab "Drivers", and tell us the displayed version number and date of the installed drivers. Do not ask Windows to check for driver updates, as it always says the driver is up to date when it might not be.

--
Sibelius 8.7/7.5.1/7.1.3/6.2/5.2.5, PhotoScore Ult 8.8.2, Dolet 6.6 for Sibelius, Windows 10 64-bit 16GB. Desktop, and Microsoft Surface Book.

Back to top | All threads
 
Re: Latency
Posted by Laurence Payne - 03 Dec 02:36PM
Realtek audio chips are certainly pretty basic, but if, along with the ASIO4ALL driver, they let you set latency low enough for Flexitime note input (silly name that, as the first priority is to turn the useless 'flexibility' functing firmly OFF) to be practical, you may need nothing more. Audio quality is perfectly acceptable, and in any case when you Export Audio of a finished score, the audio interface is irrelevant. Take the finished product to your audiophile hi-fi system if you wish!

Interesting to note that many here are very enthusiastic about NotePerformer as an alternative playback system. It is as unusable in real-time as 'Microsoft GS Wavetable Synth'.

Back to top | All threads
 
Re: Latency
Posted by Tijana - 03 Dec 07:48PM
Dear Robin and Laurence,

Thank you both for your replies. I am downloading Sibelius Sounds, it will obviously take forever (6 hours to go and only 20% downloaded), and in the meantime I am sending you the driver number in the att.

Cheers,

Tijana
Attachment Driver.jpg (112K)

Back to top | All threads
 
Re: Latency
Posted by Tijana - 04 Dec 11:16AM
Dear all,

Sibelius Sound completely solved the problem of latency. It did take time and space to install it, but it definitely paid off!! Thank you so very much!

Best regards,

Tijana

Back to top | All threads
 
Re: Latency
Posted by Tijana - 06 Dec 09:22PM
Dear all,

Here we go again :) Now, although latency is completely solved, I have a new problem, which I would not like to try to solve myself as I do not what it is. Anyhow, each time I run Sibelius now, I have "Undefined external error 40201 MMSYSTEM/OUT" message. After that, no sound is heard.

I sometimes manage to solve it through "Input device" (selecting again Alesis V61)and "Configuration" (selecting again Sibelius Sound) setup, especially after I restart Sibelius and/or laptop, but sometimes it does not help.

Obviously there is some clash in drivers or some other setup, but I do not know how to resolve it. Could you help?

Thanx a lot!

Tijana

Back to top | All threads
 
Re: Latency
Posted by Robin Walker - 06 Dec 10:24PM
> "Undefined external error 40201 MMSYSTEM/OUT" message.

A common cause of this is a combination of configurations which are incompatible with each other. The following selections are incompatible and will give that error:

1. Any playback configuration involving the player device "Microsoft GS Wavetable Synth"; with:
2. Any "Interface" selection in "Audio Engine Options" involving an "ASIO" interface.

Do not use that combination. You may use ASIO interfaces only with VST-style players such as "Sibelius Player".

If that combination does not explain your circumstances, please attach screen-shots of (1) "Playback Devices" and (2) "Audio Engine Options"

--
Sibelius 8.7/7.5.1/7.1.3/6.2/5.2.5, PhotoScore Ult 8.8.2, Dolet 6.6 for Sibelius, Windows 10 64-bit 16GB. Desktop, and Microsoft Surface Book.

Back to top | All threads
 
Re: Latency
Posted by Tijana - 07 Dec 12:36AM
Thanks, Robin.

Attached is the screenshot showing both Playback Devices and Audio Engine Options.

Best,

Tijana
Attachment Playback devices.jpg (212K)

Back to top | All threads
 
Re: Latency
Posted by Tijana - 07 Dec 12:46AM
I now went to File/Preferences and under "When starting Sibelius load this playback device", chose "Sibelius 7 Sounds". Previously it was "General MIDI (basic)".

It seems that it solved the problem. I will get back to you if I encounter the Error again.

Thanx!

Back to top | All threads
 
Re: Latency
Posted by Robin Walker - 07 Dec 08:03AM
Exactly. It was "ASIO4ALL" that caused this problem, in association with "Microsoft GS Wavetable Synth".

--
Sibelius 8.7/7.5.1/7.1.3/6.2/5.2.5, PhotoScore Ult 8.8.2, Dolet 6.6 for Sibelius, Windows 10 64-bit 16GB. Desktop, and Microsoft Surface Book.

Back to top | All threads
 
Re: Latency
Posted by James - 08 Dec 06:17PM
>It was "ASIO4ALL" that caused this problem, in association with "Microsoft GS Wavetable Synth".


Oh, so that...
...
...
...
... was the problem.







--
Mac OS 10.12 Sierra
Sibelius 6.2

Back to top | All threads
 
Re: Latency
Posted by Laurence Payne - 08 Dec 07:32PM
Well, sort of. ANY ASIO driver isn't going to work with "Microsoft GS Wavetable Synth". But the Synth is the thing to discard, not the ASIO driver.

Back to top | All threads
 

Quick reply

To add a reply to the end of this thread, type it below, then click Reply.

(.sib, .png and .jpg only)

Messages in this thread

Latency - Tijana, 02 Dec 11:33PM
     Re: Latency - Peter Roos, 03 Dec 02:17AM
         Re: Latency - Tijana, 03 Dec 09:36AM
             Re: Latency - Robin Walker, 03 Dec 10:30AM
                 Re: Latency - Tijana, 03 Dec 10:52AM
                 Re: Latency - Tijana, 03 Dec 10:53AM
                     Re: Latency - Robin Walker, 03 Dec 11:37AM
                         Re: Latency - Laurence Payne, 03 Dec 02:36PM
                             Re: Latency - Tijana, 03 Dec 07:48PM
                                 Re: Latency - Tijana, 04 Dec 11:16AM
                                     Re: Latency - Tijana, 06 Dec 09:22PM
                                         Re: Latency - Robin Walker, 06 Dec 10:24PM
                                             Re: Latency - Tijana, 07 Dec 12:36AM
                                                 Re: Latency - Tijana, 07 Dec 12:46AM
                                                     Re: Latency - Robin Walker, 07 Dec 08:03AM
                                                         Re: Latency - James, 08 Dec 06:17PM
                                                             Re: Latency - Laurence Payne, 08 Dec 07:32PM