'Sib. 7.0: Missing Font Issue in Sibelius 7'

Messages in this thread

Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 03:15AM
     Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Robin Walker, 26 Oct 09:32AM
         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Daniel Spreadbury, 26 Oct 01:26PM
             Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 09:03PM
                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Russell D, 26 Oct 09:08PM
                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Derek Bourgeois, 26 Oct 09:13PM
                     Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Robin Walker, 26 Oct 10:24PM
                         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:44PM
                             Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:45PM
                                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:46PM
                                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:47PM
                         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:45PM
                     Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:43PM
                         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Daniel Spreadbury, 27 Oct 04:52PM
                             Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 01 Nov 11:19PM

Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 03:15AM
Good morning.

MacBook 13'' Intel Core 2 Duo
iMac Intel Core 2 Duo
Mac OS X 10.6.8
Sibelius 7.0.3

We have an issue with Sibelius 7. Upon launching we get an error stating, that certain fonts are missing. Due to this we are having issues with the way that fonts are behaving for our users. The fonts are not actually missing and do appear in /Library/Fonts.

As per your knowledge base articles and other suggestions on the net, I have tried the following to no avail, to resolve the issue.

- Used Font Book to disable these font families, then re-enable the font families - Inkpen2, Opus, Reprise and Helsinki.
- Deleted the fonts, and re-install them, using the Scorch installer.
- Used Onyx to clear the "Font Cache".
- I noticed that these fonts did not exist in the User's font directory, so I copied the fonts to there, to no avail. After this I did notice that Font Book had reported duplicates of these fonts, so I removed them again.
- The permissions on the fonts are 644, so everyone has read access to them.
- I opened full permissions on these font families (777), with no result.
- I get the same error when launching Sibelius in an Administrative account.
- Trashed the user based sibelius preferences to no avail
- Removed Sibelius 7 with "App Cleaner" and performed a re-install from disk. Ended up having the exact same issue.
- Even though we have Sibelius 5 on some of our machines, thinking this maybe the issue. I have tried on a clean system, that has never had Sibelius 5 installed, and still experience the same font error.

Are there any other suggestions? Is anyone else experiencing the same issue?

Regards Chris.

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by Robin Walker - 26 Oct 09:32AM
Please attach a .sib score files that exhibits this problem.

--
Sibelius 7.0.3/6.2, PhotoScore Ult 7.0.2, Dolet 6 for Sibelius, Windows 7 32-bit SP1, 4GB RAM

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by Daniel Spreadbury - 26 Oct 01:26PM
Which specific fonts is Sibelius complaining about? All of its own fonts, or just some of them?

--
Contact Sibelius technical help online:
http://www.sibelius.com/helpcenter/contact.html

Contact Sibelius technical help by phone (charges may apply):
USA & Canada: +1 650-731-6106
UK: +44 (0)20 7561 7997
Australia: 1300 652 172
Other countries: www.sibelius.com/support

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 09:03PM
Hi Daniel.

Please see attached, the error we get when launching Sibelius 7 (error1).

The fonts families it claims are missing are from the "Opus" family.

This article

http://www.sibelius.com/cgi-bin/helpcenter/search.pl?com=search&words=A552&language=1

Talks about other font families: Inkpen2, Reprise & Helsinki.

It appears the fonts that are missing are specific to Sibelius.

Regards Chris.
Attachment error1.png (30K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by Russell D - 26 Oct 09:08PM
> •Select all of the Inkpen2, Opus, Reprise and Helsinki fonts using Command-click

Opus is in the article.

--
Sibelius 7.0.3
AMD Quad-core 9950, Vista x64 SP2, 8 GB RAM, Creative X-Fi Titanium
Kontakt 3.5, EWQLSO Platinum, EWQLSC (PLAY v3: x64), Wordbuilder

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by Derek Bourgeois - 26 Oct 09:13PM
I believe these fonts don't exist any more and they have more modern names.

I attach a png of the fonts I have in my system. I have told Sibelius not to warn me about missing fonts and to do its best to replace them. In opening over 300 old files I haven't noticed anything awry.

Derek

--
Windows 7 Ultimate 64 bit - Intel Xeon@3.47 Ghz - 24GB RAM - NVidia Quadro 5000 with 6143 graphics memory - 2.4 TB hard disks (of which 640 GB SSD) Vienna Symphonic Library Special Edition plus full percussion library. East West QL Symphonic Orchestra and Choirs. Sibelius 7 Sounds. M-Audio Fast Track.
Attachment opus fonts.PNG.png (117K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by Robin Walker - 26 Oct 10:24PM
Chris,

It appears that either (a) you have not installed any of the Sibelius 7 fonts on your network of Macs, or (b) having installed them, they have been deleted somehow. Please do not follow instructions on any old articles (such as the 552 one you quote) about deleting Sibelius fonts during trouble-shooting, because there is no way to get the Sibelius 7 fonts back, other than re-installing the Sibelius 7 application, which is what you should do now.

Please note that Sibelius 7 does not use the same fonts as earlier versions of Sibelius.

--
Sibelius 7.0.3/6.2, PhotoScore Ult 7.0.2, Dolet 6 for Sibelius, Windows 7 32-bit SP1, 4GB RAM

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 10:44PM
Hi Robin.

File 2.

Regards Chris.
Attachment Standard Helsinki.sib (81K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 10:45PM
Hi Robin.

File 4.

Regards Chris.
Attachment Standard inkpen.sib (86K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 10:46PM
Hi Robin.

File 5.

Regards Chris.
Attachment Standard Reprise - add note names to note heads.sib (51K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 10:47PM
Hi Robin.

File 6.

Regards Chris.
Attachment Standard Reprise.sib (86K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 10:45PM
Hi Robin.

File 3.

Regards Chris.
Attachment Standard inkpen -add note names to note heads.sib (51K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 26 Oct 10:43PM
Hi Robin.

The font families: Opus, Reprise, Inkpen2 & Helsinki are installed in /Library/Fonts. And they are also present in Font Book, that is the odd thing.

With your previous request, I have 6 .SIB files. I will attached them one at a time to a thread.

Regards Chris.
Attachment Standard Helsinki - add note names to note heads.sib (48K)

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by Daniel Spreadbury - 27 Oct 04:52PM
The files that should be installed are called things like OpusStd.otf, OpusTextStd.otf, OpusSpecialStd.otf, etc. Those are the Sibelius 7 fonts that it's looking for.

--
Contact Sibelius technical help online:
http://www.sibelius.com/helpcenter/contact.html

Contact Sibelius technical help by phone (charges may apply):
USA & Canada: +1 650-731-6106
UK: +44 (0)20 7561 7997
Australia: 1300 652 172
Other countries: www.sibelius.com/support

Back to top | All threads
 
Re: Sib. 7.0: Missing Font Issue in Sibelius 7
Posted by St Joseph's College - 01 Nov 11:19PM
Good morning All.

I have been in touch with Avid/Sibelius support. The following steps have resolved my issue:

---------------------------------------------------------------

Hi Chris,

Although you've been through this with "App Cleaner", I suggest you try a full manual un-installation via the instructions below and run the disk repair utility once the program's gone, followed by re-installation to a brand new administrator account.

-------------------------------------
As follows are instructions for totally removing Sibelius from your Mac.

Removing Sibelius Manually:

- Quit Sibelius then delete the specified files from:

- MacHardDrive > Users > Your Username > Library > Preferences - delete "com.sibelius.sibelius6.plist" and "siblib.plist"

- MacHardDrive > Users > Your Username > Library > Preferences - delete "siblib.plist"

- MacHardDrive > Applications - delete anything called Sibelius> i.e. Sibelius 2,3,4,5 and 6. Also delete "Kontakt Player Sibelius" if present

- MacHardDrive> Library > Application support - delete "Sibelius Software"

- MacHardDrive> Users > Your Username > Library > Application support - delete "Sibelius Software" (This may not be there)

- Delete the Sibelius Music Fonts. Go to MacHardDrive > Library > Fonts and drag to the trash any fonts called Opus, Inkpen, Inkpen 2, Helsinki and Reprise.

- Then go to MacHardDrive > Users > Your Username > Library > Fonts and trash the same ones if they exist there.

- Empty the Trash. This will make sure that Sibelius is completely off the system.

- Verify & Repair Permissions
Go to MacHardDrive>Applications>Utilities>Disk Utility - double click the icon, select the MacHD on the left and the First Aid tab on the right. Then click Verify Disk Permissions (it will take a little while to run through), then click Repair Disk Permissions when it's finished, and allow this process to complete also.

- Create a brand new Administrator user account, log into it so you can install and register the software from there. Instructions for creating user accounts on Mac can be found here if you need them:

http://docs.info.apple.com/article.html?path=Mac/10.5/en/8235.html

- Now log into the new account and run the Sibelius installation again, by running the full 7.0.3 installer from here

http://www.sibelius.com/helpcenter/updates/sib7_0_3.html

- When the installation is complete, run and register Sibelius from this same user account immediately.

*Make sure you use the password that you've created for the new Admin account that you're logged into and have installed Sibelius under when you're prompted for an Administrator Password by the registration process.

---------------------------------------------------------------

Even though we are in a school environment, there are some things I cannot do like having the students use an admin account and having a completely "fresh" system. Yet knowing these steps resolve the issue, it will give me a guide where i can "tweak" the above steps to help resolve our issue.

One I have further information, I will repost my findings.

Thanks to everyone for their input.

Regards Chris.

Back to top | All threads
 

Quick reply

To add a reply to the end of this thread, type it below, then click Reply.

(.sib, .png and .jpg only)

Messages in this thread

Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 03:15AM
     Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Robin Walker, 26 Oct 09:32AM
         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Daniel Spreadbury, 26 Oct 01:26PM
             Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 09:03PM
                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Russell D, 26 Oct 09:08PM
                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Derek Bourgeois, 26 Oct 09:13PM
                     Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Robin Walker, 26 Oct 10:24PM
                         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:44PM
                             Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:45PM
                                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:46PM
                                 Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:47PM
                         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:45PM
                     Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 26 Oct 10:43PM
                         Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - Daniel Spreadbury, 27 Oct 04:52PM
                             Re: Sib. 7.0: Missing Font Issue in Sibelius 7 - St Joseph's College, 01 Nov 11:19PM