'Sib. 6.2: Slurs not displaying correctly after Mac Java update'

Messages in this thread

Sib. 6.2: Slurs not displaying correctly after ... - Bob Hayden-Gilbert, 23 Mar 05:46AM
     Re: Sib. 6.2: Slurs not displaying correctly af... - Daniel formerly at Sibelius, 23 Mar 12:09PM
         Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 23 Mar 03:38PM
             Re: Sib. 6.2: Slurs not displaying correctly af... - Peter Danemo, 23 Mar 03:47PM
                 Re: Sib. 6.2: Slurs not displaying correctly af... - Robin Walker, 23 Mar 04:17PM
                     Re: Sib. 6.2: Slurs not displaying correctly af... - Steve Philipp, 23 Mar 07:59PM
                         Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 24 Mar 05:18AM
                             Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 31 Mar 09:25AM
                                 Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 02 Apr 02:39PM
                                     Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 18 Apr 04:19PM

Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Bob Hayden-Gilbert - 23 Mar 05:46AM
After a Mac update, which included a new version of Java, my slurs no longer displayed correctly in some scores, and also some parts within the same score. Other scores didn't seem to have the same problems.

Any other Mac users have the same problem? The "quick fix" is to turn off magnetic layout and all slurs display correctly. I even tried deleting bars and re-entering slurs, but had the strange slur problem again. The only fix was to turn off magnetic layout.
--
Mac Book Pro Intel Core Duo 2.16 GHz, OS 10.6.7, 2Gb RAM
http://www.original-works.co.uk
Attachment Screen shot Bahn Frei 2011-03-23 at 12.14.31.png (80K)

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Daniel formerly at Sibelius - 23 Mar 12:09PM
I suspect you can select just those slurs via Edit > Filter > Slurs, then disable Magnetic Layout only for those slurs using Edit > Magnetic Layout > Off and it would have the same curative effect.

The problem is most likely that you have some very dodgy Engraving Rules settings in your score.

--
Contact Sibelius technical help by email:
http://www.sibelius.com/cgi-bin/helpcenter/tech.pl

Contact Sibelius technical help by phone (charges may apply):
USA & Canada: +1 650-731-6106
UK: +44 (0)20 7561 7997
Australia: 1300 652 172
Other countries: www.sibelius.com/support

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Bob Hayden-Gilbert - 23 Mar 03:38PM
Thanks Daniel. Actually, I rarely fiddle with engraving rules, as I'm always afraid that I'll do something stupid and find it difficult to return to my status quo. I never mess with slurs or noteheads and other important things and am pretty much a "plain vanilla" user. What amazed me was that some slurs were displaying correctly whilst others were not, within the same score. Thanks for the tip about selecting slurs. If this ever occurs again, I'll use that routine. I'll investigate further to try and find out what the problem actually was. I'll also check the engraving rules.
--
Mac Book Pro Intel Core Duo 2.16 GHz, OS 10.6.7, 2Gb RAM
http://www.original-works.co.uk

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Peter Danemo - 23 Mar 03:47PM
No dodgy Engraving rules settings in my computer. No other way for me than going back to 10.6.6 with the help of Time Machine.

I think people should be warned not to update to 10.6.7!

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Robin Walker - 23 Mar 04:17PM
Have you tried the recommendations in
http://www.sibelius.com/helpcenter/en/a552 ?

--
Sibelius 6.2, PhotoScore Ult 6.1, Dolet 5.6 for Sibelius, Windows 7 SP1, 4GB RAM

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Steve Philipp - 23 Mar 07:59PM
Font issue as per the other thread. Disabling and reenabling fonts with Font Book reported to resolve this issue.

--
Sibelius 6.2, iMac - Snow Leopard and Dell XPS 420 - Windows 7. 2011

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Bob Hayden-Gilbert - 24 Mar 05:18AM
Thanks everyone for your comments. I had a problem with fonts when I updated from 10.4.11 to 10.5.6 - the dots in dotted notes wouldn't display. Daniel's quick fix was to install a new copy of Scorch which overwrites Sibelius fonts.

This current problem is extremely weird. The slurs look OK on the screen, but when I print it, the slurs are printed incorrectly, and look similar to my enclosed jpg. Printing to pdf comes out normally - no errors.

To be absolutely fair, my Sibelius has other issues - a folder in Sibelius Prefs has the number 18179 and Daniel did send me the url of a download of Sib 6 which I could install. However, as I use Sibelius all the time, I didn't want to have to re-register and run into problems doing that, so I'm still working with the "errant" version. I think that it may be time to "grasp the nettle".

Not wishing to "grasp the nettle" just yet, I thought that I would investigate the font book fix, which I tried before in 10.5.6, so I shut down Sibelius and loaded the font book, only to be greeted by a message which informed me that I had multiple Sibelius fonts installed and that I should remove them using "resolve duplicates". After I'd done that, I reloaded Sibelius and all the problems have disappeared.
--
Mac Book Pro Intel Core Duo 2.16 GHz, OS 10.6.7, 2Gb RAM
http://www.original-works.co.uk

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Bob Hayden-Gilbert - 31 Mar 09:25AM
dfonts are working fine for me. otf fonts in other apps are working as they should.
--
Mac Book Pro Intel Core Duo 2.16 GHz, OS 10.6.7, 2Gb RAM
http://www.original-works.co.uk

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Bob Hayden-Gilbert - 02 Apr 02:39PM
There's a good article on the otf problem at: http://www.planetquark.com/2011/03/29/mac-os-x-10-6-7-update-causes-problems-with-opentype-fonts/
--
Mac Book Pro Intel Core Duo 2.16 GHz, OS 10.6.7, 2Gb RAM
http://www.original-works.co.uk

Back to top | All threads
 
Re: Sib. 6.2: Slurs not displaying correctly after Mac Java update
Posted by Bob Hayden-Gilbert - 18 Apr 04:19PM
Please let Apple know how their latest "upgrade" has affected our work by leaving feedback at: http://www.apple.com/feedback/macosx.html
--
Mac Book Pro Intel Core Duo 2.16 GHz, OS 10.6.7, 2Gb RAM
http://www.original-works.co.uk

Back to top | All threads
 

Quick reply

To add a reply to the end of this thread, type it below, then click Reply.

(.sib, .png and .jpg only)

Messages in this thread

Sib. 6.2: Slurs not displaying correctly after ... - Bob Hayden-Gilbert, 23 Mar 05:46AM
     Re: Sib. 6.2: Slurs not displaying correctly af... - Daniel formerly at Sibelius, 23 Mar 12:09PM
         Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 23 Mar 03:38PM
             Re: Sib. 6.2: Slurs not displaying correctly af... - Peter Danemo, 23 Mar 03:47PM
                 Re: Sib. 6.2: Slurs not displaying correctly af... - Robin Walker, 23 Mar 04:17PM
                     Re: Sib. 6.2: Slurs not displaying correctly af... - Steve Philipp, 23 Mar 07:59PM
                         Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 24 Mar 05:18AM
                             Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 31 Mar 09:25AM
                                 Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 02 Apr 02:39PM
                                     Re: Sib. 6.2: Slurs not displaying correctly af... - Bob Hayden-Gilbert, 18 Apr 04:19PM